summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreenRaccoon232015-09-30 13:24:54 -0400
committerGreenRaccoon232015-09-30 13:24:54 -0400
commit63980b94005860762ddfadb6aa58f3cc95002181 (patch)
treef0de86d4f220ca75c0f9a81d407dc21e4febaea1
downloadaur-63980b94005860762ddfadb6aa58f3cc95002181.tar.gz
Test upload
-rw-r--r--.SRCINFO40
-rw-r--r--COPYING20
-rw-r--r--PKGBUILD45
-rw-r--r--dash-qt.desktop12
-rwxr-xr-xdash128.pngbin0 -> 2771 bytes
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7231d86345e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = dashcore
+ pkgdesc = Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool.)
+ pkgver = 0.12.0.55
+ pkgrel = 1
+ url = http://www.dashpay.io/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = binutils
+ makedepends = gcc
+ makedepends = libtool
+ makedepends = make
+ makedepends = pkg-config
+ makedepends = automoc4
+ makedepends = protobuf
+ depends = qt4
+ depends = boost
+ depends = boost-libs
+ depends = miniupnpc
+ depends = openssl
+ depends = qrencode
+ provides = dashd
+ provides = dash-qt
+ provides = dash-cli
+ conflicts = dashcore-git
+ source = dash128.png
+ source = dash-qt.desktop
+ source = COPYING
+ md5sums = 0d4112bc393f50dc2d0f7d615aa81f39
+ md5sums = 700c3a8588e7f65cdea7d433c6345ce1
+ md5sums = a959a99a436ddca2af3ddc0b428faec2
+ source_i686 = https://www.dashpay.io/binaries/dash-0.12.0.55-linux32.tar.gz
+ md5sums_i686 = 310bd1ed179911299f65035bbede4844
+ source_x86_64 = https://www.dashpay.io/binaries/dash-0.12.0.55-linux64.tar.gz
+ md5sums_x86_64 = 7645dbd0d41be87105c7f8dcf06ad105
+
+pkgname = dashcore
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..5826391abf1c
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,20 @@
+Copyright (c) 2009-2015 Bitcoin Developers
+Copyright (c) 2014-2015 Dash Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0985bd6dd88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Vertoe <vertoe AT darkcoin DOT io>
+# Contributor: Mitsu <archlinux AT suumitsu DOT eu>
+# Contributor: GreenRaccoon23 <GreenRaccoon23 AT gmail DOT com>
+# Based on PKGBUILD from darkcoin-git maintained by Viliam Kubis <viliam dot kubis at gmail dot com>
+
+pkgname='dashcore'
+_gitname='dash'
+pkgver=0.12.0.55
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.dashpay.io/"
+depends=('qt4' 'boost' 'boost-libs' 'miniupnpc' 'openssl' 'qrencode')
+makedepends=('autoconf' 'automake' 'binutils' 'gcc' 'libtool' 'make' 'pkg-config' 'automoc4' 'protobuf')
+license=('MIT')
+pkgdesc="Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool.)"
+provides=('dashd' 'dash-qt' 'dash-cli')
+conflicts=('dashcore-git')
+
+#source=("https://github.com/dashpay/dash/archive/v$pkgver.tar.gz")
+source=('dash128.png'
+ 'dash-qt.desktop'
+ 'COPYING'
+#source=('https://raw.githubusercontent.com/dashpay/dash/master/share/pixmaps/bitcoin128.png'
+# 'https://raw.githubusercontent.com/dashpay/dash/master/contrib/debian/dash-qt.desktop'
+# 'https://raw.githubusercontent.com/dashpay/dash/master/COPYING')
+)
+source_i686=("https://www.dashpay.io/binaries/dash-$pkgver-linux32.tar.gz")
+source_x86_64=("https://www.dashpay.io/binaries/dash-$pkgver-linux64.tar.gz")
+md5sums=('0d4112bc393f50dc2d0f7d615aa81f39'
+ '700c3a8588e7f65cdea7d433c6345ce1'
+ 'a959a99a436ddca2af3ddc0b428faec2')
+md5sums_i686=('310bd1ed179911299f65035bbede4844')
+md5sums_x86_64=('7645dbd0d41be87105c7f8dcf06ad105')
+
+package() {
+ install -D -m755 "$srcdir/$_gitname-${pkgver%.*}/bin/dash-qt" "$pkgdir/usr/bin/dash-qt"
+ install -D -m755 "$srcdir/$_gitname-${pkgver%.*}/bin/dashd" "$pkgdir/usr/bin/dashd"
+ install -D -m755 "$srcdir/$_gitname-${pkgver%.*}/bin/dash-cli" "$pkgdir/usr/bin/dash-cli"
+ #install -D -m644 "$srcdir/$_gitname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ #install -D -m644 "$srcdir/$_gitname-$pkgver/share/pixmaps/dash128.png" "$pkgdir/usr/share/pixmaps/dash128.png"
+ #install -D -m644 "$srcdir/$_gitname-$pkgver/contrib/debian/dash-qt.desktop" "$pkgdir/usr/share/applications/dash-qt.desktop"
+ install -D -m644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "dash128.png" "$pkgdir/usr/share/pixmaps/dash128.png"
+ install -D -m644 "dash-qt.desktop" "$pkgdir/usr/share/applications/dash-qt.desktop"
+}
diff --git a/dash-qt.desktop b/dash-qt.desktop
new file mode 100644
index 000000000000..2a2536ad6eb8
--- /dev/null
+++ b/dash-qt.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Dash
+Comment=Dash P2P Cryptocurrency
+Comment[fr]=Dash, monnaie virtuelle cryptographique pair à pair
+Comment[tr]=Dash, eşten eşe kriptografik sanal para birimi
+Exec=dash-qt %u
+Terminal=false
+Type=Application
+Icon=dash128
+MimeType=x-scheme-handler/dash;
+Categories=Office;Finance;
diff --git a/dash128.png b/dash128.png
new file mode 100755
index 000000000000..f0dc48c95aa9
--- /dev/null
+++ b/dash128.png
Binary files differ