summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2022-04-05 16:03:36 +1000
committerLuis Aranguren2022-04-05 16:03:36 +1000
commit0955d438a69e0e2dbee8a85508b0d39388729dfe (patch)
treee8526bbc629cfba1898a946ee6f7eb30e0312716
parentf32a4353d4e4e48c88e63a9aaee375455ee87824 (diff)
downloadaur-0955d438a69e0e2dbee8a85508b0d39388729dfe.tar.gz
pkgrel=2, git->git+https, bind.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--bind.patch95
3 files changed, 114 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e91f31b5b08..d4a383c8cbce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashcore-git
pkgdesc = Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool). WARNING: Unstable, development version.
pkgver = 0.17.0.3.r0.geaca69b22c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dashpay/dash
arch = x86_64
license = MIT
@@ -37,9 +37,11 @@ pkgbase = dashcore-git
conflicts = dash-daemon
source = deque.patch
source = qpainterpath.patch
- source = git://github.com/dashpay/dash.git
+ source = bind.patch
+ source = git+https://github.com/dashpay/dash.git
sha512sums = 87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5
sha512sums = 6c3df861832926e72dfd820af42bb89c1c3bb556c3f8e2fd06544f76bf5369c992a556e717653e230e062e89b8f2ee4f5d02313f35672f8174deae48c3306a0d
+ sha512sums = 775d0944fd981643450c72468140d180d35108566f9fc804460c211dce2b05552970abcc6cd233ea4f1810bb3467af8a42bdd3a6ebbbefb221f87bdec20943f0
sha512sums = SKIP
pkgname = dashcore-git
diff --git a/PKGBUILD b/PKGBUILD
index 47012a0795f2..1e9d1ba65932 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@
pkgname='dashcore-git'
_gitname='dash'
-_gitbranch='master'
+_gitbranch='v0.17.x'
pkgver=0.17.0.3.r0.geaca69b22c
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/dashpay/dash"
depends=('qt5-base' 'boost' 'boost-libs' 'miniupnpc' 'protobuf' 'db4.8' 'zeromq' 'libevent' 'qrencode' 'libbacktrace-git')
@@ -21,14 +21,16 @@ provides=('dash-daemon' 'dash-qt' 'dash-cli')
conflicts=('dashcore' 'dashcore-bin' 'dash-cli' 'dash-qt' 'dash-daemon')
source=('deque.patch'
'qpainterpath.patch'
- "git://github.com/dashpay/dash.git")
+ 'bind.patch'
+ "git+https://github.com/dashpay/dash.git")
sha512sums=('87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5'
'6c3df861832926e72dfd820af42bb89c1c3bb556c3f8e2fd06544f76bf5369c992a556e717653e230e062e89b8f2ee4f5d02313f35672f8174deae48c3306a0d'
+ '775d0944fd981643450c72468140d180d35108566f9fc804460c211dce2b05552970abcc6cd233ea4f1810bb3467af8a42bdd3a6ebbbefb221f87bdec20943f0'
'SKIP')
prepare () {
cd "$_gitname"
- git pull origin v0.17.x
+ git checkout "$_gitbranch" -q
#deque patch 2020-02-12 == http: add missing header bootlegged by boost < 1.72
#inlcude deque library in src/httpserver.cpp found in https://github.com/bitcoin/bitcoin/commit/a5929130223973636f3fd25fbfaf2953f2ec96a9 and #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
#will delete when dash fixes/commits this.
@@ -38,6 +40,15 @@ prepare () {
#include QPainterPath library in src/qt/trafficgraphwidget.cpp found in https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690
#will delete when dash fixes/commits this. This happens because dash is compiling against older versions of qt5-base
patch --forward --strip=1 --input="../../qpainterpath.patch"
+
+ #boost/bind 2022-04-05 == "Fixes error: ‘_1’ was not declared in this scope" errors
+ #Fixes issues like "xxxxxxxxx.cpp error: ‘_1’ was not declared in this scope"
+ #mentioned in https://github.com/dogecoin/dogecoin/issues/1654
+ #and fixed in https://github.com/dogecoin/dogecoin/pull/1694
+ #with commit https://github.com/dogecoin/dogecoin/pull/1694/commits/3b02ebe5002a381c291b2e221c63cc4f55823a97
+ #modified into https://github.com/mercurytoxic/dash/commit/fbdc4026851f61e70bdf49bf6a1b051d1781b474
+ patch --forward --strip=1 --input="../../bind.patch"
+
}
pkgver() {
diff --git a/bind.patch b/bind.patch
new file mode 100644
index 000000000000..23aa765f9d07
--- /dev/null
+++ b/bind.patch
@@ -0,0 +1,95 @@
+diff --git a/src/qt/bitcoingui.cpp b/src/qt/bitcoingui.cpp
+index e7e92d375..68c540d7e 100644
+--- a/src/qt/bitcoingui.cpp
++++ b/src/qt/bitcoingui.cpp
+@@ -71,6 +71,8 @@ const std::string BitcoinGUI::DEFAULT_UIPLATFORM =
+ #endif
+ ;
+
++#include <boost/bind.hpp>
++
+ BitcoinGUI::BitcoinGUI(interfaces::Node& node, const NetworkStyle* networkStyle, QWidget* parent) :
+ QMainWindow(parent),
+ enableWallet(false),
+diff --git a/src/qt/clientmodel.cpp b/src/qt/clientmodel.cpp
+index df8c8792a..a88997ed8 100644
+--- a/src/qt/clientmodel.cpp
++++ b/src/qt/clientmodel.cpp
+@@ -28,6 +28,8 @@
+ #include <QDebug>
+ #include <QTimer>
+
++#include <boost/bind.hpp>
++
+ static int64_t nLastHeaderTipUpdateNotification = 0;
+ static int64_t nLastBlockTipUpdateNotification = 0;
+
+diff --git a/src/qt/splashscreen.cpp b/src/qt/splashscreen.cpp
+index 80c46d1ea..27ca83bbf 100644
+--- a/src/qt/splashscreen.cpp
++++ b/src/qt/splashscreen.cpp
+@@ -27,6 +27,8 @@
+ #include <QDesktopWidget>
+ #include <QPainter>
+
++#include <boost/bind.hpp>
++
+ SplashScreen::SplashScreen(interfaces::Node& node, Qt::WindowFlags f, const NetworkStyle *networkStyle) :
+ QWidget(0, f), curAlignment(0), m_node(node)
+ {
+diff --git a/src/qt/transactiontablemodel.cpp b/src/qt/transactiontablemodel.cpp
+index 062f10a4a..5a75b60b0 100644
+--- a/src/qt/transactiontablemodel.cpp
++++ b/src/qt/transactiontablemodel.cpp
+@@ -24,6 +24,8 @@
+ #include <QIcon>
+ #include <QList>
+
++#include <boost/bind.hpp>
++
+ // Amount column is right-aligned it contains numbers
+ static int column_alignments[] = {
+ Qt::AlignLeft|Qt::AlignVCenter, /* status */
+diff --git a/src/qt/walletmodel.cpp b/src/qt/walletmodel.cpp
+index 0b7a5cd80..a682ddfa6 100644
+--- a/src/qt/walletmodel.cpp
++++ b/src/qt/walletmodel.cpp
+@@ -28,6 +28,7 @@
+ #include <QSet>
+ #include <QTimer>
+
++#include <boost/bind.hpp>
+
+ WalletModel::WalletModel(std::unique_ptr<interfaces::Wallet> wallet, interfaces::Node& node, OptionsModel *_optionsModel, QObject *parent) :
+ QObject(parent), m_wallet(std::move(wallet)), m_node(node), optionsModel(_optionsModel), addressTableModel(0),
+diff --git a/src/validation.cpp b/src/validation.cpp
+index 66963fc44..d5718dc5e 100644
+--- a/src/validation.cpp
++++ b/src/validation.cpp
+@@ -54,6 +54,7 @@
+
+ #include <boost/algorithm/string/replace.hpp>
+ #include <boost/thread.hpp>
++#include <boost/bind.hpp>
+
+ #if defined(NDEBUG)
+ # error "Dash Core cannot be compiled without assertions."
+diff --git a/src/validationinterface.cpp b/src/validationinterface.cpp
+index 4760f8923..b821ae9b0 100644
+--- a/src/validationinterface.cpp
++++ b/src/validationinterface.cpp
+@@ -23,6 +23,7 @@
+ #include <future>
+
+ #include <boost/signals2/signal.hpp>
++#include <boost/bind.hpp>
+
+ struct MainSignalsInstance {
+ boost::signals2::signal<void (const CBlockIndex *, const CBlockIndex *, bool fInitialDownload)> UpdatedBlockTip;
+@@ -274,4 +275,4 @@ void CMainSignals::NotifyRecoveredSig(const std::shared_ptr<const llmq::CRecover
+
+ void CMainSignals::NotifyMasternodeListChanged(bool undo, const CDeterministicMNList& oldMNList, const CDeterministicMNListDiff& diff) {
+ m_internals->NotifyMasternodeListChanged(undo, oldMNList, diff);
+-}
+\ No newline at end of file
++}