summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2021-06-04 14:04:06 +1000
committerLuis Aranguren2021-06-04 14:04:06 +1000
commit58fbfc817c3534e5c03ab577f8644fdb19d1709a (patch)
treeab6a355f5700f0142fb9da8f0b15a912d51ed127
parent412d4597e294847f994bbffaa3fc79ca9f15eea7 (diff)
downloadaur-58fbfc817c3534e5c03ab577f8644fdb19d1709a.tar.gz
pkgrel=3, included qpainterpath.patch and updated checksum
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--qpainterpath.patch22
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6147350e8a98..96efa75194d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashcore-git
pkgdesc = Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool). WARNING: Unstable, development version.
pkgver = 0.17.0.2.r0.g79a1b1aa47
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dashpay/dash
arch = x86_64
license = MIT
@@ -36,10 +36,10 @@ pkgbase = dashcore-git
conflicts = dash-qt
conflicts = dash-daemon
source = deque.patch
- source = qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch
+ source = qpainterpath.patch
source = git://github.com/dashpay/dash.git
sha512sums = 87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5
- sha512sums = 1eda9a1d5616a0602f85b0d04838657fe5fa75746a2da7a4614124e6081eeb1997e845d61a7d7a9a52a9d5ef9215617205924811cfef32132bf7fce9c3c603fb
+ sha512sums = 6c3df861832926e72dfd820af42bb89c1c3bb556c3f8e2fd06544f76bf5369c992a556e717653e230e062e89b8f2ee4f5d02313f35672f8174deae48c3306a0d
sha512sums = SKIP
pkgname = dashcore-git
diff --git a/PKGBUILD b/PKGBUILD
index 078c77d825a9..7d76e95ff666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname='dashcore-git'
_gitname='dash'
_gitbranch='master'
pkgver=0.17.0.2.r0.g79a1b1aa47
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/dashpay/dash"
depends=('qt5-base' 'boost' 'boost-libs' 'miniupnpc' 'protobuf' 'db4.8' 'zeromq' 'libevent' 'qrencode' 'libbacktrace-git')
@@ -20,10 +20,10 @@ pkgdesc="Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy
provides=('dash-daemon' 'dash-qt' 'dash-cli')
conflicts=('dashcore' 'dashcore-bin' 'dash-cli' 'dash-qt' 'dash-daemon')
source=('deque.patch'
- 'qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch'
+ 'qpainterpath.patch'
"git://github.com/dashpay/dash.git")
sha512sums=('87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5'
- '1eda9a1d5616a0602f85b0d04838657fe5fa75746a2da7a4614124e6081eeb1997e845d61a7d7a9a52a9d5ef9215617205924811cfef32132bf7fce9c3c603fb'
+ '6c3df861832926e72dfd820af42bb89c1c3bb556c3f8e2fd06544f76bf5369c992a556e717653e230e062e89b8f2ee4f5d02313f35672f8174deae48c3306a0d'
'SKIP')
prepare () {
diff --git a/qpainterpath.patch b/qpainterpath.patch
new file mode 100644
index 000000000000..51a25cb5a87f
--- /dev/null
+++ b/qpainterpath.patch
@@ -0,0 +1,22 @@
+From 79b0a69e09c1a912122e6431ea3c530cc292c690 Mon Sep 17 00:00:00 2001
+From: Andrew Chow <achow101-github@achow101.com>
+Date: Thu, 28 May 2020 14:56:47 -0400
+Subject: [PATCH] Add missing QPainterPath include
+
+This is needed to compile with Qt 5.15.
+---
+ src/qt/trafficgraphwidget.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+index 757648f4854d2..6428fc4dafc89 100644
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -7,6 +7,7 @@
+ #include <qt/clientmodel.h>
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QColor>
+ #include <QTimer>
+