summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2020-02-13 12:51:46 +1100
committerLuis Aranguren2020-02-13 12:51:46 +1100
commit9f1e3098d6a12081683341f5770bd2565b38639a (patch)
treeddcb5497a16285108dd2ca9e51bacbb2b089b964
parent44b6b0dcfbc4c20711a4b8d67d4d6524b8046e67 (diff)
downloadaur-9f1e3098d6a12081683341f5770bd2565b38639a.tar.gz
v0.15.0.0.rc3.r5.gf23e722da, added libbacktrace-git dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--deque.patch7
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4ae32ddc833..37e6134e13f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashcore-git
pkgdesc = Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool). WARNING: Unstable, development version.
- pkgver = v0.14.0.5.r0.g2ae1ce480
- pkgrel = 3
+ pkgver = v0.15.0.0.rc3.r5.gf23e722da
+ pkgrel = 1
url = https://github.com/dashpay/dash
arch = x86_64
license = MIT
@@ -17,6 +17,7 @@ pkgbase = dashcore-git
makedepends = python3
makedepends = cmake
makedepends = codablock-bls-signatures
+ makedepends = libbacktrace-git
depends = qt5-base
depends = boost
depends = boost-libs
@@ -31,7 +32,9 @@ pkgbase = dashcore-git
provides = dash-cli
conflicts = dashcore
conflicts = dashcore-bin
+ source = deque.patch
source = git://github.com/dashpay/dash.git
+ sha512sums = 87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5
sha512sums = SKIP
pkgname = dashcore-git
diff --git a/PKGBUILD b/PKGBUILD
index b0fcaf8adc1a..128105a2c7e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,22 +9,24 @@
pkgname='dashcore-git'
_gitname='dash'
_gitbranch='master'
-pkgver=v0.14.0.5.r0.g2ae1ce480
-pkgrel=3
+pkgver=v0.15.0.0.rc3.r5.gf23e722da
+pkgrel=1
arch=('x86_64')
url="https://github.com/dashpay/dash"
depends=('qt5-base' 'boost' 'boost-libs' 'miniupnpc' 'protobuf' 'db4.8' 'zeromq' 'libevent' 'qrencode')
-makedepends=('autoconf' 'automake' 'binutils' 'gcc' 'libtool' 'make' 'pkg-config' 'git' 'qt5-tools' 'python3' 'cmake' 'codablock-bls-signatures')
+makedepends=('autoconf' 'automake' 'binutils' 'gcc' 'libtool' 'make' 'pkg-config' 'git' 'qt5-tools' 'python3' 'cmake' 'codablock-bls-signatures' 'libbacktrace-git')
license=('MIT')
pkgdesc="Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool). WARNING: Unstable, development version."
provides=('dashd' 'dash-qt' 'dash-cli')
conflicts=('dashcore' 'dashcore-bin')
-source=("git://github.com/dashpay/dash.git")
-sha512sums=('SKIP')
+source=('deque.patch'
+ "git://github.com/dashpay/dash.git")
+sha512sums=('87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5'
+ 'SKIP')
prepare () {
cd "$_gitname"
- git pull origin v0.14.0.x
+ git pull origin v0.15.x
#deque patch 2020-02-12
#inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
#will delete when dash fixes/commits this.
diff --git a/deque.patch b/deque.patch
index 8649cecfbe1d..197f8450c5f3 100644
--- a/deque.patch
+++ b/deque.patch
@@ -47,12 +47,11 @@ diff --git a/src/httpserver.cpp b/src/httpserver.cpp
index dba9527305..5c08e676df 100644
--- a/src/httpserver.cpp
+++ b/src/httpserver.cpp
-@@ -19,6 +19,7 @@
+@@ -21,6 +21,7 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <signal.h>
+#include <deque>
- #include <future>
- #include <event2/event.h>
-
+ #include <event2/thread.h>
+ #include <event2/buffer.h>