summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2020-10-12 19:16:29 +1100
committerLuis Aranguren2020-10-12 19:16:29 +1100
commitcc8041cf2ee9cb9e4cedcbafda38d3244fe75e08 (patch)
tree9aeaec86a46e025fdb4006bba98006bd0174a215
parentfb0efe0e1613afcd098f39de81db12620c21e70d (diff)
downloadaur-cc8041cf2ee9cb9e4cedcbafda38d3244fe75e08.tar.gz
v0.16.0.1.r0.gb3c8306867, qpainterpath patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0be58bca0625..4e7750103746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashcore-git
pkgdesc = Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy-centric digital currency. (Includes the qt-client, the headless daemon and the command-line tool). WARNING: Unstable, development version.
- pkgver = v0.15.0.0.r0.g351fbf65e
- pkgrel = 2
+ pkgver = v0.16.0.1.r0.gb3c8306867
+ pkgrel = 1
url = https://github.com/dashpay/dash
arch = x86_64
license = MIT
@@ -36,8 +36,10 @@ pkgbase = dashcore-git
conflicts = dash-qt
conflicts = dash-daemon
source = deque.patch
+ source = qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch
source = git://github.com/dashpay/dash.git
sha512sums = 87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5
+ sha512sums = 1eda9a1d5616a0602f85b0d04838657fe5fa75746a2da7a4614124e6081eeb1997e845d61a7d7a9a52a9d5ef9215617205924811cfef32132bf7fce9c3c603fb
sha512sums = SKIP
pkgname = dashcore-git
diff --git a/PKGBUILD b/PKGBUILD
index dec5ae214035..2e2a80a35369 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
pkgname='dashcore-git'
_gitname='dash'
_gitbranch='master'
-pkgver=v0.15.0.0.r0.g351fbf65e
-pkgrel=2
+pkgver=v0.16.0.1.r0.gb3c8306867
+pkgrel=1
arch=('x86_64')
url="https://github.com/dashpay/dash"
depends=('qt5-base' 'boost' 'boost-libs' 'miniupnpc' 'protobuf' 'db4.8' 'zeromq' 'libevent' 'qrencode' 'libbacktrace-git')
@@ -20,17 +20,24 @@ pkgdesc="Dash Core (DASH, Dashpay, formerly Darkcoin) is an open source, privacy
provides=('dash-daemon' 'dash-qt' 'dash-cli')
conflicts=('dashcore' 'dashcore-bin' 'dash-cli' 'dash-qt' 'dash-daemon')
source=('deque.patch'
+ 'qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch'
"git://github.com/dashpay/dash.git")
sha512sums=('87c8fbe782a66222fd1121d61bde967d89e6ddda2f1a4dfc7f17eabfce1502ce172af13f52d94d752464ee125fa69d9b423f495baa52bde1fe02e4762aa889d5'
+ '1eda9a1d5616a0602f85b0d04838657fe5fa75746a2da7a4614124e6081eeb1997e845d61a7d7a9a52a9d5ef9215617205924811cfef32132bf7fce9c3c603fb'
'SKIP')
prepare () {
cd "$_gitname"
git pull origin v0.15.x
- #deque patch 2020-02-12
- #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
+ #deque patch 2020-02-12 == http: add missing header bootlegged by boost < 1.72
+ #inlcude deque library in src/httpserver.cpp found in https://github.com/bitcoin/bitcoin/commit/a5929130223973636f3fd25fbfaf2953f2ec96a9 and #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
#will delete when dash fixes/commits this.
patch --forward --strip=1 --input="../../deque.patch"
+
+ #QPainterPath 2020-10-12 == Add missing QPainterPath include
+ #include QPainterPath library in src/qt/trafficgraphwidget.cpp found in https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690
+ #will delete when dash fixes/commits this. This happens because dash is compiling against older versions of qt5-base
+ patch --forward --strip=1 --input="../../qpainterpath.patch"
}
pkgver() {