aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Koglin-Fischer2023-12-21 14:15:41 +0100
committerStephan Koglin-Fischer2023-12-21 14:43:27 +0100
commit237990e29243d807e1ac94da0af791a2836ade52 (patch)
treeb47d159b7b509ea17a5c2b837f931543ac8fe774
parent0e24320c5e13b5d69eb2ea77b5d0401e032af12b (diff)
downloadaur-237990e29243d807e1ac94da0af791a2836ade52.tar.gz
feat: check that the source of the asdf is not contained in any shell config
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cab7fa5d5099..8432c3a338a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashlane-cli-git
pkgdesc = Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version.
pkgver = v1.15.1.r0.g8368d87
- pkgrel = 41
+ pkgrel = 43
url = https://github.com/Dashlane/dashlane-cli
install = .INSTALL
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e3aeda05ae60..f4fd5cf5d29c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephan Koglin-Fischer <stephan dot koglin-fischer at funzt dot dev>
pkgname=dashlane-cli-git
pkgver=v1.15.1.r0.g8368d87
-pkgrel=41
+pkgrel=43
pkgdesc="Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version."
arch=('x86_64')
url="https://github.com/Dashlane/dashlane-cli"
@@ -31,14 +31,14 @@ check-for-asdf() {
# for bash, fish, zsh - add more if needed
if [[ $SHELL == *"bash"* ]]; then
# If the .bashrc file does not contain the asdf source command, we add it
- if ! grep -q "source /opt/asdf-vm/asdf.sh" ~/.bashrc; then
- echo -e "\nsource /opt/asdf-vm/asdf.sh" >> ~/.bashrc
+ if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.bashrc; then
+ echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.bashrc
fi
source ~/.bashrc
elif [[ $SHELL == *"fish"* ]]; then
# If the config.fish file does not contain the asdf source command, we add it
- if ! grep -q "source /opt/asdf-vm/asdf.fish" ~/.config/fish/config.fish; then
- echo -e "\nsource /opt/asdf-vm/asdf.fish" >> ~/.config/fish/config.fish
+ if ! grep -q ". /opt/asdf-vm/asdf.fish" ~/.config/fish/config.fish; then
+ echo -e "\n. /opt/asdf-vm/asdf.fish" >> ~/.config/fish/config.fish
fi
source ~/.config/fish/config.fish
elif [[ $SHELL == *"zsh"* ]]; then
@@ -52,8 +52,8 @@ check-for-asdf() {
echo -e "#!/usr/bin/env zsh\n# Shebang added by the dashlane-cli-git package\n\n$(cat ~/.zshrc)" > ~/.zshrc
fi
# If the .zshrc file does not contain the asdf source command, we add it
- if ! grep -q "source /opt/asdf-vm/asdf.sh" ~/.zshrc; then
- echo -e "\nsource /opt/asdf-vm/asdf.sh" >> ~/.zshrc
+ if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.zshrc; then
+ echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.zshrc
fi
source ~/.zshrc
else