aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Koglin-Fischer2023-12-21 15:02:43 +0100
committerStephan Koglin-Fischer2023-12-21 15:56:12 +0100
commit315eaf61150781b702cdbb760a070adf51114a1a (patch)
tree330a356649c8a2197b784780f141fdfe2000a13f
parent00b7b7bdbae111fa49f16d5f34edcbb3d72ffe98 (diff)
downloadaur-315eaf61150781b702cdbb760a070adf51114a1a.tar.gz
bump: 1.15.1.r0.g8368d87.45
-rw-r--r--PKGBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7bfbd0f394e0..a8e552f60700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,7 @@
# Maintainer: Stephan Koglin-Fischer <stephan dot koglin-fischer at funzt dot dev>
pkgname=dashlane-cli-git
pkgver=v1.15.1.r0.g8368d87
-<<<<<<< HEAD
pkgrel=56
-=======
-pkgrel=44
->>>>>>> d4ca0d4 (feat: check that the source of the asdf is not contained in any shell config)
pkgdesc="Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version."
arch=('x86_64')
url="https://github.com/Dashlane/dashlane-cli"
@@ -25,53 +21,6 @@ pkgver() {
git describe --long --tags --abbrev=7 | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-<<<<<<< HEAD
-=======
-check-for-asdf() {
- if ! command -v asdf &> /dev/null
- then
- echo "asdf could not be found"
- echo "Configuring asdf..."
-
- # Install asdf
- # for bash, fish, zsh - add more if needed
- if [[ $SHELL == *"bash"* ]]; then
- # If the .bashrc file does not contain the asdf source command, we add it
- if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.bashrc; then
- echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.bashrc
- fi
- source ~/.bashrc
- elif [[ $SHELL == *"fish"* ]]; then
- # If the config.fish file does not contain the asdf source command, we add it
- if ! grep -q ". /opt/asdf-vm/asdf.fish" ~/.config/fish/config.fish; then
- echo -e "\n. /opt/asdf-vm/asdf.fish" >> ~/.config/fish/config.fish
- fi
- source ~/.config/fish/config.fish
- elif [[ $SHELL == *"zsh"* ]]; then
- # Just to make sure that an existing zsh config is not intervening,
- # we need to check that the .zshrc file contains the proper shebang #!/usr/bin/env zsh
- if ! grep -q "#!/usr/bin/env zsh" ~/.zshrc; then
- echo "The .zshrc file does not contain the proper shebang #!/usr/bin/env zsh"
- echo "This script is likely to fail."
- echo "For convenience, we will add it for you."
- echo "If you do not want this, please remove it manually after the installation has finished."
- echo -e "#!/usr/bin/env zsh\n# Shebang added by the dashlane-cli-git package\n\n$(cat ~/.zshrc)" > ~/.zshrc
- fi
- # If the .zshrc file does not contain the asdf source command, we add it
- if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.zshrc; then
- echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.zshrc
- fi
- source ~/.zshrc
- else
- echo "Unsupported shell. Please add asdf to your shell's initialization file manually."
- echo "Consider opening an issue or contribute a pull request to add support for your shell."
- echo "https://github.com/skf-funzt/dashlane-cli-git"
- exit 1
- fi
- fi
-}
-
->>>>>>> d4ca0d4 (feat: check that the source of the asdf is not contained in any shell config)
prepare() {
$SHELL -c "source ./commands.sh && prepare_commands $srcdir $pkgname"
}