aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Koglin-Fischer2023-12-21 16:07:45 +0100
committerStephan Koglin-Fischer2023-12-21 16:07:45 +0100
commit491ea501f80eff6cfc9f6454566fad51b789f052 (patch)
tree97e1f7e705fd9eb97ab1004b83729c49692239ae
parent34c93834d86b9d04736162a513b639d429e31ca0 (diff)
downloadaur-491ea501f80eff6cfc9f6454566fad51b789f052.tar.gz
chore: lost the track but now I should on it again
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--commands.sh36
3 files changed, 4 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 317ad43a4ad9..840fefff7392 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashlane-cli-git
pkgdesc = Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version.
pkgver = v1.15.1.r0.g8368d87
- pkgrel = 56
+ pkgrel = 60
url = https://github.com/Dashlane/dashlane-cli
install = .INSTALL
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a8e552f60700..196b5a3b4ad9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephan Koglin-Fischer <stephan dot koglin-fischer at funzt dot dev>
pkgname=dashlane-cli-git
pkgver=v1.15.1.r0.g8368d87
-pkgrel=56
+pkgrel=60
pkgdesc="Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version."
arch=('x86_64')
url="https://github.com/Dashlane/dashlane-cli"
diff --git a/commands.sh b/commands.sh
index 85cc1638e8cd..56ae73b19d9c 100644
--- a/commands.sh
+++ b/commands.sh
@@ -1,9 +1,5 @@
check-for-asdf() {
-<<<<<<< HEAD
- if ! commands -v asdf &> /dev/null
-=======
if ! command -v asdf &> /dev/null
->>>>>>> 5292e5c (fix: still doesn't work)
then
echo "asdf could not be found"
echo "Configuring asdf..."
@@ -11,22 +7,14 @@ check-for-asdf() {
# Install asdf
# for bash, fish, zsh - add more if needed
if [[ $SHELL == *"bash"* ]]; then
-<<<<<<< HEAD
- # If the .bashrc file does not contain the asdf source commands, we add it
-=======
# If the .bashrc file does not contain the asdf source command, we add it
->>>>>>> 5292e5c (fix: still doesn't work)
if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.bashrc; then
echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.bashrc
fi
source ~/.bashrc
elif [[ $SHELL == *"fish"* ]]; then
echo "Patching config.fish"
-<<<<<<< HEAD
- # If the config.fish file does not contain the asdf source commands, we add it
-=======
# If the config.fish file does not contain the asdf source command, we add it
->>>>>>> 5292e5c (fix: still doesn't work)
if ! grep -q ". /opt/asdf-vm/asdf.fish" ~/.config/fish/config.fish; then
echo -e "\n. /opt/asdf-vm/asdf.fish" >> ~/.config/fish/config.fish
fi
@@ -42,22 +30,14 @@ check-for-asdf() {
echo "If you do not want this, please remove it manually after the installation has finished."
echo -e "#!/usr/bin/env zsh\n# Shebang added by the dashlane-cli-git package\n\n$(cat ~/.zshrc)" > ~/.zshrc
fi
-<<<<<<< HEAD
- # If the .zshrc file does not contain the asdf source commands, we add it
-=======
# If the .zshrc file does not contain the asdf source command, we add it
->>>>>>> 5292e5c (fix: still doesn't work)
if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.zshrc; then
echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.zshrc
fi
source ~/.zshrc
# Check if asdf is available now
-<<<<<<< HEAD
- if ! commands -v asdf &> /dev/null
+ if ! command -v asdf &> /dev/null
then
-=======
- if ! command -v asdf &> /dev/null then
->>>>>>> 5292e5c (fix: still doesn't work)
echo "asdf could not be found"
echo "You need to add asdf to your shell's initialization file manually."
fi
@@ -70,14 +50,10 @@ check-for-asdf() {
fi
}
-<<<<<<< HEAD
prepare_commands() {
local srcdir=$1
local pkgname=$2
-=======
-prepare_command() {
->>>>>>> 5292e5c (fix: still doesn't work)
check-for-asdf
# Install all plugins stated in .tool-versions
@@ -88,31 +64,23 @@ prepare_command() {
yarn install
}
-<<<<<<< HEAD
build_commands() {
local srcdir=$1
local pkgname=$2
-=======
-build_command() {
->>>>>>> 5292e5c (fix: still doesn't work)
check-for-asdf
-
+
cd "$srcdir/$pkgname"
yarn run build
# Build linux binary
yarn pkg:linux
}
-<<<<<<< HEAD
package_commands() {
local srcdir=$1
local pkgname=$2
local pkgdir=$3
-=======
-package_command() {
->>>>>>> 5292e5c (fix: still doesn't work)
check-for-asdf
cd "$srcdir/$pkgname"