aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Koglin-Fischer2023-12-21 16:12:44 +0100
committerStephan Koglin-Fischer2023-12-21 16:12:44 +0100
commitb3d63f5d9b9aa953ec558e78d02cb559d9bd4aca (patch)
treede87b0a9daf989bf0f770057a1bd76f290c1bf92
parent5292e5c7f65ce1046f96a2228ad263f8e46d1a83 (diff)
parente14bab68ce42ced5b8735b10d48d0ad3c8aab435 (diff)
downloadaur-b3d63f5d9b9aa953ec558e78d02cb559d9bd4aca.tar.gz
Merge branch 'main'
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--commands.sh21
3 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e21ef326b12f..82cccfafca17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashlane-cli-git
pkgdesc = Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version.
pkgver = v1.15.1.r0.g8368d87
- pkgrel = 49
+ pkgrel = 61
url = https://github.com/Dashlane/dashlane-cli
install = .INSTALL
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 369cb09e7906..2816f1b5695a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephan Koglin-Fischer <stephan dot koglin-fischer at funzt dot dev>
pkgname=dashlane-cli-git
pkgver=v1.15.1.r0.g8368d87
-pkgrel=49
+pkgrel=61
pkgdesc="Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version."
arch=('x86_64')
url="https://github.com/Dashlane/dashlane-cli"
@@ -22,13 +22,13 @@ pkgver() {
}
prepare() {
- $SHELL -c "source ./commands.sh && prepare_commands"
+ $SHELL -c "source ./commands.sh && prepare_commands $srcdir $pkgname"
}
build() {
- $SHELL -c "source ./commands.sh && build_commands"
+ $SHELL -c "source ./commands.sh && build_commands $srcdir $pkgname"
}
package() {
- $SHELL -c "source ./commands.sh && package_commands"
+ $SHELL -c "source ./commands.sh && package_commands $srcdir $pkgname $pkgdir"
}
diff --git a/commands.sh b/commands.sh
index 8fc7143fc703..56ae73b19d9c 100644
--- a/commands.sh
+++ b/commands.sh
@@ -36,7 +36,8 @@ check-for-asdf() {
fi
source ~/.zshrc
# Check if asdf is available now
- if ! command -v asdf &> /dev/null then
+ if ! command -v asdf &> /dev/null
+ then
echo "asdf could not be found"
echo "You need to add asdf to your shell's initialization file manually."
fi
@@ -49,7 +50,10 @@ check-for-asdf() {
fi
}
-prepare_command() {
+prepare_commands() {
+ local srcdir=$1
+ local pkgname=$2
+
check-for-asdf
# Install all plugins stated in .tool-versions
@@ -60,16 +64,23 @@ prepare_command() {
yarn install
}
-build_command() {
+build_commands() {
+ local srcdir=$1
+ local pkgname=$2
+
check-for-asdf
-
+
cd "$srcdir/$pkgname"
yarn run build
# Build linux binary
yarn pkg:linux
}
-package_command() {
+package_commands() {
+ local srcdir=$1
+ local pkgname=$2
+ local pkgdir=$3
+
check-for-asdf
cd "$srcdir/$pkgname"