aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Koglin-Fischer2023-12-19 08:49:32 +0100
committerStephan Koglin-Fischer2023-12-19 08:49:32 +0100
commitdc8046f5bdda8bb1191c6e51454c39e33b26ee71 (patch)
tree759cc45b32b34c3becf509d750b4a54094fe1260
parentcdc5655b2d88c0d5ecb4e389e0655df75c508a9a (diff)
downloadaur-dc8046f5bdda8bb1191c6e51454c39e33b26ee71.tar.gz
bump: 1.15.1.r0.g8368d87.37
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--justfile4
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae502cc701af..e22c368c6024 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashlane-cli-git
pkgdesc = Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version.
pkgver = v1.15.1.r0.g8368d87
- pkgrel = 36
+ pkgrel = 37
url = https://github.com/Dashlane/dashlane-cli
install = .INSTALL
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6787b5dbce10..54852ac62151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephan Koglin-Fischer <stephan dot koglin-fischer at funzt dot dev>
pkgname=dashlane-cli-git
pkgver=v1.15.1.r0.g8368d87
-pkgrel=36
+pkgrel=37
pkgdesc="Dashlane CLI GitHub repository version bundled with asdf-vm to ensure using the correct node version."
arch=('x86_64')
url="https://github.com/Dashlane/dashlane-cli"
@@ -21,7 +21,7 @@ pkgver() {
git describe --long --tags --abbrev=7 | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
+check-for-asdf() {
if ! command -v asdf &> /dev/null
then
echo "asdf could not be found"
@@ -43,6 +43,10 @@ prepare() {
exit 1
fi
fi
+}
+
+prepare() {
+ check-for-asdf
# Install all plugins stated in .tool-versions
awk '{print $1}' .tool-versions | xargs -n 1 asdf plugin-add
@@ -53,6 +57,8 @@ prepare() {
}
build() {
+ check-for-asdf
+
cd "$srcdir/$pkgname"
yarn run build
# Build linux binary
@@ -60,6 +66,8 @@ build() {
}
package() {
+ check-for-asdf
+
cd "$srcdir/$pkgname"
# Install the tool-versions file
diff --git a/justfile b/justfile
index cd1c3ac85d58..dae366f2fa7e 100644
--- a/justfile
+++ b/justfile
@@ -59,8 +59,8 @@ publish: prepare
@echo -e "\e[36mNew version: $(just src-version)\e[0m"
@git add .
@echo -e "\e[36mCommitting and tagging...\e[0m"
- @git commit -m "bump: $(just src-version)"
- @git tag -af $(just tag-name) -m "bump: $(just src-version)"
+ @git tag -af $(just tag-name) -m "bump: $(just src-version).$(just commit-count)"
+ @git commit -m "bump: $(just src-version).$(just commit-count)"
@echo -e "\e[36mPushing to origin...\e[0m"
@git push || true
@git push --tags --force