aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Koglin-Fischer2023-12-21 15:42:40 +0100
committerStephan Koglin-Fischer2023-12-21 15:42:40 +0100
commitede67895444cb8161671eacdc26b7fc065d8080b (patch)
treedfbc6440c9875d78a19e075ec58dee0b3e75d3b3
parent7c2f21240f9b8c6a3c7f7f03c00e9df2f639d733 (diff)
downloadaur-ede67895444cb8161671eacdc26b7fc065d8080b.tar.gz
fix: still doesn't work
-rw-r--r--PKGBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfda16d0b56a..369cb09e7906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,56 +21,6 @@ pkgver() {
git describe --long --tags --abbrev=7 | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-<<<<<<< Updated upstream
-check-for-asdf() {
- if ! command -v asdf &> /dev/null
- then
- echo "asdf could not be found"
- echo "Configuring asdf..."
-
- # Install asdf
- # for bash, fish, zsh - add more if needed
- if [[ $SHELL == *"bash"* ]]; then
- # If the .bashrc file does not contain the asdf source command, we add it
- if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.bashrc; then
- echo "Patching .bashrc"
- echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.bashrc
- fi
- source ~/.bashrc
- elif [[ $SHELL == *"fish"* ]]; then
- echo "Patching config.fish"
- # If the config.fish file does not contain the asdf source command, we add it
- if ! grep -q ". /opt/asdf-vm/asdf.fish" ~/.config/fish/config.fish; then
- echo -e "\n. /opt/asdf-vm/asdf.fish" >> ~/.config/fish/config.fish
- fi
- source ~/.config/fish/config.fish
- elif [[ $SHELL == *"zsh"* ]]; then
- echo "Patching .zshrc"
- # Just to make sure that an existing zsh config is not intervening,
- # we need to check that the .zshrc file contains the proper shebang #!/usr/bin/env zsh
- if ! grep -q "#!/usr/bin/env zsh" ~/.zshrc; then
- echo "The .zshrc file does not contain the proper shebang #!/usr/bin/env zsh"
- echo "This script is likely to fail."
- echo "For convenience, we will add it for you."
- echo "If you do not want this, please remove it manually after the installation has finished."
- echo -e "#!/usr/bin/env zsh\n# Shebang added by the dashlane-cli-git package\n\n$(cat ~/.zshrc)" > ~/.zshrc
- fi
- # If the .zshrc file does not contain the asdf source command, we add it
- if ! grep -q ". /opt/asdf-vm/asdf.sh" ~/.zshrc; then
- echo -e "\n. /opt/asdf-vm/asdf.sh" >> ~/.zshrc
- fi
- source ~/.zshrc
- else
- echo "Unsupported shell. Please add asdf to your shell's initialization file manually."
- echo "Consider opening an issue or contribute a pull request to add support for your shell."
- echo "https://github.com/skf-funzt/dashlane-cli-git"
- exit 1
- fi
- fi
-}
-
-=======
->>>>>>> Stashed changes
prepare() {
$SHELL -c "source ./commands.sh && prepare_commands"
}