summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Mezentsev2023-10-07 17:17:42 +0300
committerSergey Mezentsev2023-10-07 17:17:42 +0300
commit606a2a211a2972f0bff0c9bb01cbcb54efccc9b5 (patch)
tree8894a45c92b238f978e568b25eecf9f8bbad923a
downloadaur-606a2a211a2972f0bff0c9bb01cbcb54efccc9b5.tar.gz
31.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3aef82c158e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = datafusion-cli
+ pkgdesc = The DataFusion CLI is a command-line interactive SQL utility for executing queries against any supported data files.
+ pkgver = 31.0.0
+ pkgrel = 1
+ url = https://github.com/apache/arrow-datafusion
+ arch = x86_64
+ license = APACHE
+ makedepends = rustup
+ makedepends = cargo
+ source = datafusion-cli-31.0.0.tar.gz::https://github.com/apache/arrow-datafusion/archive/tags/31.0.0.tar.gz
+ b2sums = 87c5af9b8afcd1032ab49597fae3e7c7f48654e817455307d3c305854b895462c5b35b1f998486226b943b94357d36694ac753b85e20791eba24db1ab934112f
+
+pkgname = datafusion-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6478bcf03db4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sergey Mezentsev <thebits@yandex.ru>
+
+pkgname=datafusion-cli
+pkgver=31.0.0
+pkgrel=1
+pkgdesc="The DataFusion CLI is a command-line interactive SQL utility for executing queries against any supported data files."
+url="https://github.com/apache/arrow-datafusion"
+arch=(x86_64)
+license=(APACHE)
+makedepends=(
+ rustup
+ cargo
+)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/apache/arrow-datafusion/archive/tags/$pkgver.tar.gz")
+b2sums=('87c5af9b8afcd1032ab49597fae3e7c7f48654e817455307d3c305854b895462c5b35b1f998486226b943b94357d36694ac753b85e20791eba24db1ab934112f')
+
+build() {
+ export CARGO_TARGET_DIR=target
+ cd "arrow-datafusion-tags-$pkgver/datafusion-cli"
+ rustup override set 1.70
+ rustup component add rustfmt
+ cargo build --release
+}
+
+#check() {
+# cd "arrow-datafusion-tags-$pkgver"
+# cargo test --frozen --all-features
+#}
+
+package() {
+ cd "arrow-datafusion-tags-$pkgver/datafusion-cli"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+ cd ..
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dt "$pkgdir/usr/share/doc/$pkgname" -m644 {README,CHANGELOG}.md
+}