summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2019-02-15 23:43:07 +0300
committerNikolay Korotkiy2019-02-15 23:43:07 +0300
commit30c5533e2cde423148dd28d46088965ae027df4c (patch)
treeb115ae3bb10f6def0a41178acb911ebe62a39e99
parentc32ecfd5fcbddc6cdd173fadcd972ea95139c27e (diff)
downloadaur-30c5533e2cde423148dd28d46088965ae027df4c.tar.gz
Add parse-gpx
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e2d35b5305f..3a5522ed1974 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-# Generated by makepkg 5.1.1
-# Wed Nov 28 09:07:05 UTC 2018
+# Generated by makepkg 5.1.2
+# Fri Feb 15 20:41:24 UTC 2019
pkgbase = datamaps-git
pkgdesc = Indexes points and lines and generates map tiles to display them
pkgver = r290.76e620a
@@ -10,9 +10,12 @@ pkgbase = datamaps-git
license = BSD
makedepends = git
depends = libpng
+ depends = perl-xml-parser
provides = datamaps=r290.76e620a
conflicts = datamaps
source = datamaps-master::git://github.com/ericfischer/datamaps.git#branch=master
+ source = https://raw.githubusercontent.com/ericfischer/gpx-layer/master/parse-gpx
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = datamaps-git
diff --git a/.gitignore b/.gitignore
index 3ede74253e66..c766e663c390 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.*
datamaps-*
+parse-gpx
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 529bfbf0a9c4..fb2d1f75f4f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
_orgname=ericfischer
_pkgname=datamaps
_branch=master
+_with_parser=true
pkgname=${_pkgname}-git
pkgver=r290.76e620a
pkgrel=1
@@ -10,11 +11,18 @@ arch=('i686' 'x86_64')
url='https://github.com/ericfischer/datamaps'
license=('BSD')
depends=('libpng')
+if [ "${_with_parser}" = true ]; then
+ depends+=('perl-xml-parser')
+fi
makedepends=('git')
provides=("${pkgname//-git}=${pkgver}")
conflicts=(${pkgname//-git})
source=("${_pkgname}-${_branch}::git://github.com/${_orgname}/${_pkgname}.git#branch=${_branch}")
sha256sums=('SKIP')
+if [ "${_with_parser}" = true ]; then
+ source+=("https://raw.githubusercontent.com/${_orgname}/gpx-layer/master/parse-gpx")
+ sha256sums+=('SKIP')
+fi
pkgver() {
cd ${_pkgname}-${_branch}
@@ -26,9 +34,7 @@ pkgver() {
}
build() {
- cd ${_pkgname}-${_branch}
-
- make
+ make -C ${_pkgname}-${_branch}
}
package() {
@@ -37,5 +43,8 @@ package() {
for tool in encode enumerate merge render; do
install -Dm755 ${tool} ${pkgdir}/usr/bin/${_pkgname}-${tool}
done
+ if [ "${_with_parser}" = true ]; then
+ install -Dm755 ../parse-gpx ${pkgdir}/usr/bin/${_pkgname}-parse-gpx
+ fi
install -Dm644 LICENSE.md ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
}