summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2017-03-25 00:33:27 -0700
committerGavin Lloyd2017-03-25 00:33:27 -0700
commit9d5d14881e34a6449ae57ac2df51f946de80f393 (patch)
tree192a0f872d5787d7fd05aca1e64d087b64eb304e
parent6211bc632e211aeeadf25a0b9472cfbcff059d5c (diff)
downloadaur-9d5d14881e34a6449ae57ac2df51f946de80f393.tar.gz
1.1.1-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
2 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abcf9c8f269f..3e87d996d965 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Mar 25 07:33:26 UTC 2017
pkgbase = datamash
- pkgdesc = A command-line program which performs numeric, textual and statistical operations on plain text data.
+ pkgdesc = Performs basic numeric,textual and statistical operations on input textual data files
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/datamash/
arch = i686
arch = x86_64
@@ -9,7 +11,6 @@ pkgbase = datamash
depends = glibc
source = https://ftp.gnu.org/gnu/datamash/datamash-1.1.1.tar.gz
source = https://ftp.gnu.org/gnu/datamash/datamash-1.1.1.tar.gz.sig
- validpgpkeys = F576AAAC1B0FF849792D8CB129A794FD2272BC86
sha256sums = 420819b3d7372ee3ce704add847cff7d08c4f8176c1d48735d4a632410bb801b
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d1b40226dcd5..06f52740dc7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
-# Maintainer: Timothy Rice <timothy.rice@unimelb.edu.au>
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Timothy Rice <timothy.rice@unimelb.edu.au>
pkgname=datamash
pkgver=1.1.1
-pkgrel=1
-pkgdesc="A command-line program which performs numeric, textual and statistical operations on plain text data."
+pkgrel=2
+pkgdesc='Performs basic numeric,textual and statistical operations on input textual data files'
arch=('i686' 'x86_64')
+license=('GPL')
url="https://www.gnu.org/software/datamash/"
-license=("GPL")
depends=('glibc')
-source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig})
-
+source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz.sig")
sha256sums=('420819b3d7372ee3ce704add847cff7d08c4f8176c1d48735d4a632410bb801b'
'SKIP')
-
validpgpkeys=('F576AAAC1B0FF849792D8CB129A794FD2272BC86')
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
}
check() {
- cd "$pkgname-$pkgver"
- make check
+ cd "$pkgname-$pkgver"
+
+ make check
}
package() {
- cd "$pkgname-$pkgver/"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
}