summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-05-11 20:00:12 -0500
committerCarlos Aznarán Laos2022-05-11 20:00:12 -0500
commit85fc3b3276901def49116934e20bdcc359921ad0 (patch)
tree4a6fe297fbdbbe93e2315b4ef0d40292ddd6cebc
parent4c55955784a5d81e43549113d2e0ad523ce76f21 (diff)
downloadaur-85fc3b3276901def49116934e20bdcc359921ad0.tar.gz
Bump version to 20200619
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD122
2 files changed, 41 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 079ecd8868d7..2d41b1ba5eae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Mon Dec 26 23:38:45 UTC 2016
pkgbase = dataplot
pkgdesc = Software for scientific visualization, statistical analysis, and non-linear modeling.
- pkgver = 2016_12_09
- pkgrel = 2
- url = http://www.itl.nist.gov/div898/software/dataplot.html/
- arch = i686
+ pkgver = 20200619
+ pkgrel = 1
+ url = https://www.itl.nist.gov/div898/software/dataplot
arch = x86_64
license = custom
makedepends = imagemagick
makedepends = gcc-fortran
makedepends = gendesk
+ depends = cairo
depends = gd
depends = gcc-libs
depends = fontconfig
@@ -24,15 +22,9 @@ pkgbase = dataplot
depends = readline
depends = termcap
depends = tk
- noextract = dpsrc_2016_12_09.tar.gz
- noextract = dplib.tar.gz
- backup = usr/share/dataplot/frscript/xdpConfig
- source = http://www.itl.nist.gov/div898/software/dataplot/ftp/unix/dpsrc_2016_12_09.tar.gz
- source = http://www.itl.nist.gov/div898/software/dataplot/ftp/unix/dplib.tar.gz
+ source = https://www.itl.nist.gov/div898/software/dataplot/ftp/unix/dataplot-20200619.tar.gz
source = dataplot.sh
- md5sums = b46dcb3b49487da6ab1d4989f6b84739
- md5sums = 0d0c534cf995c1b1119d9437835de068
- md5sums = d212f5842a9bab712d6353dbb66198d8
+ sha512sums = f9947d7da49f99f9fe3b69390ef3e3f143b01889049fc86b3bf2969271df1f84d64cb300481971220548b011e4824b471f2e9b7a55db406876f891b1dd01add9
+ sha512sums = 62d40b182ec2212a0cf27ac548a3a4b46598291c7407dbb8d51633bf088841b3bdf1917c0b223c3d234e8eb149aba3a0ec5d35ac66a4ac4f1521a485ca87a411
pkgname = dataplot
-
diff --git a/PKGBUILD b/PKGBUILD
index 20a9a64c3ddf..7c9c2805500f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,101 +3,60 @@
# Thanks to Alan Heckert from NIST for his support
pkgname=dataplot
-pkgver=2016_12_09
-pkgrel=2
+pkgver=20200619
+pkgrel=1
pkgdesc="Software for scientific visualization, statistical analysis, and non-linear modeling."
-arch=('i686' 'x86_64')
-url="http://www.itl.nist.gov/div898/software/dataplot.html/"
+arch=('x86_64')
+url="https://www.itl.nist.gov/div898/software/${pkgname}"
license=('custom')
-depends=('gd' 'gcc-libs' 'fontconfig' 'expat' 'libpng' 'zlib' 'libjpeg' 'libx11' 'freetype2' 'tcsh' 'readline' 'termcap' 'tk')
+depends=('cairo' 'gd' 'gcc-libs' 'fontconfig' 'expat' 'libpng' 'zlib' 'libjpeg' 'libx11' 'freetype2' 'tcsh' 'readline' 'termcap' 'tk')
makedepends=('imagemagick' 'gcc-fortran' 'gendesk')
-backup=('usr/share/dataplot/frscript/xdpConfig')
-source=("http://www.itl.nist.gov/div898/software/dataplot/ftp/unix/dpsrc_${pkgver}.tar.gz"
- "http://www.itl.nist.gov/div898/software/dataplot/ftp/unix/dplib.tar.gz"
- "dataplot.sh")
-noextract=("dpsrc_${pkgver}.tar.gz"
- "dplib.tar.gz")
+# backup=('usr/share/dataplot/frscript/xdpConfig')
+source=("${url}/ftp/unix/dataplot-${pkgver}.tar.gz"
+ "dataplot.sh")
+sha512sums=('f9947d7da49f99f9fe3b69390ef3e3f143b01889049fc86b3bf2969271df1f84d64cb300481971220548b011e4824b471f2e9b7a55db406876f891b1dd01add9'
+ '62d40b182ec2212a0cf27ac548a3a4b46598291c7407dbb8d51633bf088841b3bdf1917c0b223c3d234e8eb149aba3a0ec5d35ac66a4ac4f1521a485ca87a411')
+
+prepare() {
+ sed -i 's/\/local//g' ${pkgname}/src/Makefile
+ sed -i 's/\/local//g' ${pkgname}/lib/frscript/xdpConfig.in
+}
build() {
- cd ${srcdir}
gendesk -n -f \
- --pkgname="x${pkgname}" \
- --pkgdesc="${pkgdesc}" \
- --name="xdataplot" \
- --categories="Education;Science;Math;" \
- --exec="/usr/bin/xdataplot" \
- --startupnotify=true
-
- # Make the directory for dataplot source files
- if [ ! -d ${srcdir}/dpsrc ];then
- mkdir -p ${srcdir}/dpsrc
- fi
- cd ${srcdir}/dpsrc
- bsdtar -xf ${srcdir}/dpsrc_${pkgver}.tar.gz
-
- _build_script=build_linux_gfortran.bash
-
- # I prefer not to sacrifice precision and/or good behaviour for speed
- # If you want speed, just comment the next line
- sed -i 's@IOPT="-O1"@#IOPT="-O1"@' ${srcdir}/dpsrc/${_build_script}
-
- # By default, the build script is for 64 bit machines, so I change it in case of
- # compiling the package in a 32 bit machine
- if [ "${CARCH}" = "i686" ]; then
- sed -i 's@IBIT=64@#IBIT=64@' ${srcdir}/dpsrc/${_build_script}
- sed -i 's@#IBIT=32@IBIT=32@' ${srcdir}/dpsrc/${_build_script}
- fi
-
- # Running the build script
- chmod +x ${_build_script}
- ./${_build_script}
+ --pkgname="x${pkgname}" \
+ --pkgdesc="${pkgdesc}" \
+ --name="${pkgname}" \
+ --categories="Education;Science;Math;" \
+ --exec="/usr/bin/xdataplot" \
+ --startupnotify=true
+
+ cd ${pkgname}/src
+ make
}
package() {
- cd ${srcdir}/dpsrc
-
- # Moving the dataplot binary to ${pkgdir}
- install -dm755 ${pkgdir}/usr/bin/
- install -m755 ${srcdir}/dpsrc/dataplot ${pkgdir}/usr/bin/dataplot
+ cd ${pkgname}/src
+ make install DESTDIR="${pkgdir}"
# Preparing the dataplot auxiliary files
- install -dm755 ${pkgdir}/usr/share/dataplot/
- cd ${pkgdir}/usr/share/dataplot/
- bsdtar -xf ${srcdir}/dplib.tar.gz
-
- # Modifying the xdataplot script
- sed -i 's@#set tcl_prefix = /usr/local/lib@set tcl_prefix = /usr@' frscript/xdataplot
- sed -i "s@/lib/dataplot/@/share/dataplot/@g" frscript/xdataplot
- sed -i "s@/lib/frscript/@/share/dataplot/frscript/@g" frscript/xdataplot
-
- source /usr/lib/tclConfig.sh
- sed -i "s@/lib/tcl@/lib/tcl${TCL_VERSION}@" frscript/xdataplot
-
- source /usr/lib/tkConfig.sh
- sed -i "s@/lib/tk@/lib/tk${TK_VERSION}@" frscript/xdataplot
-
- # Modifying the config file of xdataplot
- sed -i 's@dataplot unix /usr/local/bin/dataplot@dataplot unix /usr/bin/dataplot@' frscript/xdpConfig
- sed -i 's@library unix /usr/local/lib/dataplot@library unix /usr/share/dataplot@' frscript/xdpConfig
-
- # Symbolic link for xdataplot in /usr/bin
- ln -s /usr/share/dataplot/frscript/xdataplot ${pkgdir}/usr/bin/xdataplot
+ install -dm755 ${pkgdir}/usr/share/${pkgname}
# Icon and .desktop files
install -dm755 ${pkgdir}/usr/share/pixmaps
- /usr/bin/convert ${pkgdir}/usr/share/dataplot/frscript/xdpIcon.xbm \
- ${pkgdir}/usr/share/pixmaps/xdataplot.png
+ /usr/bin/convert ${pkgdir}/usr/lib/dataplot/frscript/xdpIcon.xbm \
+ ${pkgdir}/usr/share/pixmaps/xdataplot.png
install -dm755 ${pkgdir}/usr/share/applications
- install -m644 ${srcdir}/xdataplot.desktop ${pkgdir}/usr/share/applications/
+ install -m644 ${srcdir}/xdataplot.desktop ${pkgdir}/usr/share/applications
# Copying dataplot.sh to ${pkgdir}/etc/profile.d so dataplot will know
# where its files are
- install -dm755 ${pkgdir}/etc/profile.d/
- cp ${srcdir}/dataplot.sh ${pkgdir}/etc/profile.d/
-
+ install -dm755 ${pkgdir}/etc/profile.d
+ cp ${srcdir}/dataplot.sh ${pkgdir}/etc/profile.d
+
# License/Disclaimer
install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
- cat > ${pkgdir}/usr/share/licenses/${pkgname}/${pkgname}.txt << EOF
+ cat >${pkgdir}/usr/share/licenses/${pkgname}/${pkgname}.txt <<EOF
http://www.itl.nist.gov/div898/software/dataplot/disclaim.htm
DATAPLOT Disclaimer
@@ -110,17 +69,4 @@ NIST assumes no responsibility whatsoever for its use by other parties, and make
guarantees, expressed or implied, about its quality, reliability, or any other
characteristic.
EOF
-
- # Correcting the permissions and user/group owners
- find ${pkgdir}/ -type f -exec chmod 644 {} \;
- find ${pkgdir}/ -type d -exec chmod 755 {} \;
- chown -R root:root ${pkgdir}/*
- chmod 755 ${pkgdir}/etc/profile.d/dataplot.sh
- chmod 755 ${pkgdir}/usr/bin/dataplot
- chmod 755 ${pkgdir}/usr/share/dataplot/frscript/xdataplot
- chmod 755 ${pkgdir}/usr/share/dataplot/frscript/xdp
}
-
-md5sums=('b46dcb3b49487da6ab1d4989f6b84739'
- '0d0c534cf995c1b1119d9437835de068'
- 'd212f5842a9bab712d6353dbb66198d8')