summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjsonijr@gmail.com2023-04-01 15:38:51 -0300
committerjsonijr@gmail.com2023-04-01 15:38:51 -0300
commitb2bdae03ad7733eff2cc98faf47877d2d40056f4 (patch)
treeb6ca1b4526e5be4c21517bfd2b00b2a2425a1988
downloadaur-b2bdae03ad7733eff2cc98faf47877d2d40056f4.tar.gz
sync
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9267c20d4a26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = datediff.sh
+ pkgdesc = Calculate elapsed time. Check moon phases, Easter dates and next Friday 13th.
+ pkgver = 0.23.5
+ pkgrel = 1
+ url = https://github.com/mountaineerbr/shellDatediff
+ arch = any
+ license = GPL3
+ depends = ksh
+ optdepends = date: convert input to iso-8601
+ optdepends = bc: fractional time units (bash)
+ source = https://github.com/mountaineerbr/shellDatediff/releases/download/v0.23.5/shellDatediff.tar.zst
+ sha256sums = bc2e303ee264f131de5b53580784c89fbdb6d3cb22592ecc5e9bd1a7496c1fdf
+
+pkgname = datediff.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06dc45b6b43f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jamil SN <jamilbio20@gmail.com>
+pkgname='datediff.sh'
+_pkgname='shellDatediff' #repo
+pkgver=0.23.5
+pkgrel=1
+pkgdesc='Calculate elapsed time. Check moon phases, Easter dates and next Friday 13th.'
+url='https://github.com/mountaineerbr/shellDatediff'
+arch=('any')
+license=('GPL3')
+depends=('ksh')
+optdepends=(
+ 'date: convert input to iso-8601'
+ 'bc: fractional time units (bash)'
+)
+source=("https://github.com/mountaineerbr/${_pkgname}/releases/download/v${pkgver}/${_pkgname}.tar.zst")
+sha256sums=('bc2e303ee264f131de5b53580784c89fbdb6d3cb22592ecc5e9bd1a7496c1fdf')
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 "${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}