summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorteza NourelahiAlamdari2021-07-03 11:04:15 +0200
committerMorteza NourelahiAlamdari2021-07-03 11:04:15 +0200
commit0b5d10c017f1d987636482407b0684a276961080 (patch)
treef54fc70879fbd347e3ce9dd4b39a90ce62553ba3
downloadaur-0b5d10c017f1d987636482407b0684a276961080.tar.gz
Add datree project
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e378003fd3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = datree
+ pkgdesc = Prevent Kubernetes misconfigurations from reaching production (again triumph)! Datree is a CLI tool to ensure K8s manifests and Helm charts follow best practices as well as your organization’s policies.
+ pkgver = 0.1.503
+ pkgrel = 1
+ url = https://github.com/datreeio/datree
+ arch = x86_64
+ license = Apache-2.0
+ source = https://github.com/datreeio/datree/releases/download/0.1.503/datree-cli_0.1.503_Linux_x86_64.zip
+ sha256sums = b7865ded73dc56d36d7fa43e7ff6913de12605722f17e59886f13370fd5b8260
+
+pkgname = datree
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a897a26c7281
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Morteza NourelahiAlamdari <m@0t1.me>
+
+pkgname="datree"
+pkgver="0.1.503"
+pkgrel=1
+pkgdesc="Prevent Kubernetes misconfigurations from reaching production (again triumph)! Datree is a CLI tool to ensure K8s manifests and Helm charts follow best practices as well as your organization’s policies."
+arch=('x86_64')
+url="https://github.com/datreeio/datree"
+license=('Apache-2.0')
+source=("https://github.com/datreeio/${pkgname}/releases/download/${pkgver}/${pkgname}-cli_${pkgver}_Linux_x86_64.zip")
+sha256sums=('b7865ded73dc56d36d7fa43e7ff6913de12605722f17e59886f13370fd5b8260')
+
+package() {
+ mkdir -p "${pkgdir}/usr/local/bin"
+ install -Dm755 "${pkgname}" "$pkgdir/usr/local/bin/${pkgname}"
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE.md' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}