summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2020-07-03 03:50:31 +0200
committerPellegrino Prevete2020-07-03 03:50:31 +0200
commit2488c8236285f9ec1cf211881c936a34d3033bd3 (patch)
tree5c86f5ca06a41824319d2f7759411c100b341cc4
parenta18ce375a2f4ace08f8fe0b306fe695fc79cd271 (diff)
downloadaur-2488c8236285f9ec1cf211881c936a34d3033bd3.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56d487b7132f..aae997013d16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = daty-git
pkgdesc = Daty Wikidata Editor
- pkgver = 0.1
+ pkgver = 1.0beta+78+g81b9736
pkgrel = 1
url = https://gitlab.gnome.org/World/daty
arch = any
license = AGPLv3
+ makedepends = git
makedepends = python-setuptools
depends = libhandy
depends = python-appdirs
@@ -17,7 +18,7 @@ pkgbase = daty-git
provides = daty
conflicts = daty
source = daty::git+https://gitlab.gnome.org/World/Daty.git
- sha256sums = SKIP
+ sha512sums = SKIP
pkgname = daty-git
diff --git a/PKGBUILD b/PKGBUILD
index f42c7657c928..aaaa401e2c47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
_pkgname=daty
+_commit=81b97361
pkgname=$_pkgname-git
-pkgver=0.1
+pkgver=1.0beta+78+g81b9736
pkgrel=1
pkgdesc='Daty Wikidata Editor'
url='https://gitlab.gnome.org/World/daty'
license=('AGPLv3')
arch=('any')
depends=('libhandy' 'python-appdirs' 'python-bleach' 'python-beautifulsoup4' 'python-gobject' 'python-requests' 'python-setproctitle' 'python-pywikibot')
-makedepends=('python-setuptools')
+makedepends=('git' 'python-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
source=('daty::git+https://gitlab.gnome.org/World/Daty.git')
-sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
package() {
cd "${_pkgname}"
python3 setup.py install --root="${pkgdir}" --optimize=1
}
+
+check() (
+ glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/$_pkgname/data}"
+ export GSETTINGS_SCHEMA_DIR
+)