summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2018-12-16 12:47:49 +0100
committerPellegrino Prevete2018-12-16 12:47:49 +0100
commit4c32d5b336b16ca0fc410a2dae28cdabe18c60d3 (patch)
tree401f6faf98ae108df6f8df246ee447f8373d465b
downloadaur-4c32d5b336b16ca0fc410a2dae28cdabe18c60d3.tar.gz
initial release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD20
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65762eebe2a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = daty-git
+ pkgdesc = Daty Wikidata Editor
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/tallero/daty
+ arch = any
+ license = AGPLv3
+ makedepends = python-setuptools
+ depends = libhandy
+ depends = python-appdirs
+ depends = python-bleach
+ depends = python-beautifulsoup4
+ depends = python-gobject
+ depends = python-requests
+ depends = python-setproctitle
+ depends = python-pywikibot
+ provides = daty
+ conflicts = daty
+ source = daty::git+https://gitlab.com/tallero/daty.git
+ sha256sums = SKIP
+
+pkgname = daty-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2bc380d819c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+pkgname=daty-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='Daty Wikidata Editor'
+url='https://gitlab.com/tallero/daty'
+license=('AGPLv3')
+arch=('any')
+depends=('libhandy' 'python-appdirs' 'python-bleach' 'python-beautifulsoup4' 'python-gobject' 'python-requests' 'python-setproctitle' 'python-pywikibot')
+makedepends=('python-setuptools')
+provides=('daty')
+conflicts=('daty')
+source=('daty::git+https://gitlab.com/tallero/daty.git')
+sha256sums=('SKIP')
+
+package() {
+ cd "daty"
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+}