summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-28 19:05:01 +0200
committerPellegrino Prevete2023-06-28 19:05:01 +0200
commit8ee011bc76b159679e1d82bd0148ac6199ccbe96 (patch)
tree7b568c3df07971ec637b7a077e103fb5c90ec93d
parent91109d69845e5576a3c8ce4fe2055c10ce529295 (diff)
downloadaur-8ee011bc76b159679e1d82bd0148ac6199ccbe96.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8823674cb2d..b4cb2c715792 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = daty-git
pkgdesc = Daty Wikidata Editor
- pkgver = 1.0beta+78+g81b9736
- pkgrel = 4
+ pkgver = 1.0beta+81+g1a5dce4
+ pkgrel = 2
url = https://gitlab.gnome.org/World/daty
- arch = any
+ arch = x86_64
license = AGPLv3
makedepends = git
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 5c70bdf22772..524bded395fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,36 @@
-# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
# Contributor: John Beard <john.j.beard@gmail.com>
# shellcheck disable=SC2034
_pkgname=daty
-pkgname=$_pkgname-git
+pkgname="${_pkgname}-git"
pkgver=1.0beta+81+g1a5dce4
-pkgrel=1
+pkgrel=2
pkgdesc='Daty Wikidata Editor'
-url='https://gitlab.gnome.org/World/daty'
+url="https://gitlab.gnome.org/World/${_pkgname}"
license=('AGPLv3')
arch=('x86_64')
-depends=('libhandy0' 'python-appdirs' 'python-bleach' 'python-beautifulsoup4' 'python-gobject' 'python-requests' 'python-setproctitle' 'python-pywikibot')
-makedepends=('git' 'python-setuptools')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=("$_pkgname::git+$url.git")
+depends=(
+ 'libhandy0'
+ 'python-appdirs'
+ 'python-bleach'
+ 'python-beautifulsoup4'
+ 'python-gobject'
+ 'python-requests'
+ 'python-setproctitle'
+ 'python-pywikibot'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}