summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2015-06-29 13:30:40 +0200
committerStefan Tatschner2015-06-29 13:30:40 +0200
commit640e5d3223c9765d437388defccefee96f27b340 (patch)
tree8b5bea83ee289824aeda1133a1d3a46a615a6999
downloadaur-640e5d3223c9765d437388defccefee96f27b340.tar.gz
Initial upload: davical 1.1.3.1-1
-rw-r--r--.AURINFO29
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD53
-rw-r--r--README.archlinux57
-rw-r--r--davical.install13
-rw-r--r--httpd-davical.conf39
6 files changed, 220 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..492ac3961bf5
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,29 @@
+pkgbase = davical
+ pkgdesc = A server for calendar sharing
+ pkgver = 1.1.3.1
+ pkgrel = 1
+ url = https://gitlab.com/davical-project/davical
+ install = davical.install
+ arch = any
+ license = GPL
+ license = LGPL
+ depends = php>=5.1
+ depends = awl>=0.55
+ depends = php-pgsql
+ depends = perl-dbd-pg
+ depends = perl-yaml
+ depends = perl-dbi
+ optdepends = postgresql: run postgresql locally
+ optdepends = apache: Web server to run davical
+ optdepends = nginx: Web server to run davical
+ optdepends = php-ldap: PHP module for ldap support
+ backup = etc/webapps/davical/localhost-conf.php
+ source = davical.tar.gz::https://gitlab.com/davical-project/davical/repository/archive.tar.gz?ref=r1.1.3.1
+ source = httpd-davical.conf
+ source = README.archlinux
+ sha256sums = 4439c2df0052241b65c61eb4f0b10c406d93afd65a5cc6b523b597c0a7b05c15
+ sha256sums = cbcfee6967549baafa313de96f94b61b44c80e0e0eaa3d7309523ff721645db8
+ sha256sums = 619dce9a16e5dffa650954f78d793f93cf8034f51a6d3936d513fa8d78da5778
+
+pkgname = davical
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..492ac3961bf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = davical
+ pkgdesc = A server for calendar sharing
+ pkgver = 1.1.3.1
+ pkgrel = 1
+ url = https://gitlab.com/davical-project/davical
+ install = davical.install
+ arch = any
+ license = GPL
+ license = LGPL
+ depends = php>=5.1
+ depends = awl>=0.55
+ depends = php-pgsql
+ depends = perl-dbd-pg
+ depends = perl-yaml
+ depends = perl-dbi
+ optdepends = postgresql: run postgresql locally
+ optdepends = apache: Web server to run davical
+ optdepends = nginx: Web server to run davical
+ optdepends = php-ldap: PHP module for ldap support
+ backup = etc/webapps/davical/localhost-conf.php
+ source = davical.tar.gz::https://gitlab.com/davical-project/davical/repository/archive.tar.gz?ref=r1.1.3.1
+ source = httpd-davical.conf
+ source = README.archlinux
+ sha256sums = 4439c2df0052241b65c61eb4f0b10c406d93afd65a5cc6b523b597c0a7b05c15
+ sha256sums = cbcfee6967549baafa313de96f94b61b44c80e0e0eaa3d7309523ff721645db8
+ sha256sums = 619dce9a16e5dffa650954f78d793f93cf8034f51a6d3936d513fa8d78da5778
+
+pkgname = davical
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4381728c3eeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Stefan Tatschner <stefan@sevenbyte.org>
+# Contributor: Nikolay Amiantov <nikoamia@gmail.com>
+# Contributor: Andre Wayand <aur-davical@awayand.sleepmail.com>
+# Contributor: <zenlord@gmail.com>
+# Contributor: Michael Seiwald <michael@mseiwald.at>
+
+pkgname=davical
+pkgver=1.1.3.1
+pkgrel=1
+pkgdesc="A server for calendar sharing"
+arch=('any')
+url="https://gitlab.com/davical-project/davical"
+license=('GPL' 'LGPL')
+depends=('php>=5.1' 'awl>=0.55' 'php-pgsql' 'perl-dbd-pg' 'perl-yaml' 'perl-dbi')
+optdepends=('postgresql: run postgresql locally'
+ 'apache: Web server to run davical'
+ 'nginx: Web server to run davical'
+ 'php-ldap: PHP module for ldap support')
+backup=("etc/webapps/davical/localhost-conf.php")
+install="$pkgname.install"
+source=("${pkgname}.tar.gz::https://gitlab.com/davical-project/davical/repository/archive.tar.gz?ref=r${pkgver}"
+ httpd-davical.conf
+ README.archlinux)
+sha256sums=('4439c2df0052241b65c61eb4f0b10c406d93afd65a5cc6b523b597c0a7b05c15'
+ 'cbcfee6967549baafa313de96f94b61b44c80e0e0eaa3d7309523ff721645db8'
+ '619dce9a16e5dffa650954f78d793f93cf8034f51a6d3936d513fa8d78da5778')
+
+_instdir="/usr/share/webapps/davical"
+_docdir="/usr/share/doc/davical"
+_etcdir="/etc/webapps/davical"
+
+build() {
+ cd "${srcdir}/${pkgname}.git"
+
+ find -type f -exec sed -i "s%/etc/davical/%/etc/webapps/davical/%g" {} \;
+ cd dba
+ find -name \*.sql -exec sed -i "s/'SQL'/'sql'/g; s/'PlPgSQL'/'plpgsql'/g" {} \;
+}
+
+package() {
+ cd "${srcdir}/${pkgname}.git"
+
+ install -d \
+ "${pkgdir}${_instdir}" \
+ "${pkgdir}${_etcdir}" \
+ "${pkgdir}${_docdir}"
+
+ cp -ra . "${pkgdir}${_instdir}"
+
+ install -D -m 0644 "config/example-config.php" "${pkgdir}${_etcdir}/localhost-conf.php"
+ install -D -m 0644 "${srcdir}/README.archlinux" "${pkgdir}${_docdir}/README.archlinux"
+ install -D -m 0644 "${srcdir}/httpd-davical.conf" "${pkgdir}${_docdir}/httpd-davical.conf"
+}
diff --git a/README.archlinux b/README.archlinux
new file mode 100644
index 000000000000..aa78ddc1828d
--- /dev/null
+++ b/README.archlinux
@@ -0,0 +1,57 @@
+If you are going to use apache, you can
+edit the file /etc/httpd/conf/extra/httpd-davical.conf in your apache
+config if you want to have a vhost other than "localhost".
+
+Add the following in /etc/httpd/conf/httpd.conf at the end:
+
+Include conf/extra/httpd-davical.conf
+
+Also make sure to uncomment the following in /etc/php/php.ini:
+extension=gettext.so
+extension=iconv.so
+extension=pdo_pgsql.so
+extension=pgsql.so
+
+Restart apache: sudo apachectl restart
+
+Rename /etc/davical/localhost-conf.php to xxx-conf.php if you named your
+vhost in httpd-davical.conf xxx and edit the file to your needs
+
+If you are installing postgresql for the first time start
+it first: sudo rc.d start postgresql
+This will create /var/lib/postgres/data/pg_hba.conf
+
+Now edit this file to add the following
+at the end:
+
+local davical davical_dba trust
+local davical davical_app trust
+
+Restart postgresql: sudo rc.d restart postgresql
+
+Then create the davical database: first become root, then become user
+postgres. For example:
+
+sudo su
+su - postgres
+
+Then, you are ready to execute
+/srv/http/davical/dba/create-database.sh
+as the user postgres.
+
+IMPORTANT!
+Write down the password for
+the admin user that is displayed
+
+Logout of postgres user and root user after you have written down
+the admin user and password using:
+
+logout
+logout
+
+Use your browser to navigate to http://localhost/davical or the vhost
+you have edited in httpd-davical.conf
+
+Login using admin and the password that you written down above.
+
+More info about install and config: http://davical.org
diff --git a/davical.install b/davical.install
new file mode 100644
index 000000000000..a1a4995bae0f
--- /dev/null
+++ b/davical.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "Please read /usr/share/doc/davical/README.archlinux"
+ echo "for first-time setup installation instructions"
+}
+
+post_upgrade() {
+ echo "Upgrading..."
+ echo "Please run the following:"
+ echo ""
+ echo "sudo su"
+ echo "su - postgres"
+ echo "/usr/share/webapps/davical/dba/update-davical-database"
+}
diff --git a/httpd-davical.conf b/httpd-davical.conf
new file mode 100644
index 000000000000..a71cf1674145
--- /dev/null
+++ b/httpd-davical.conf
@@ -0,0 +1,39 @@
+Alias /davical "/srv/http/davical/htdocs"
+<Directory "/srv/http/davical/htdocs/">
+ DirectoryIndex index.php index.html
+ AcceptPathInfo On
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ php_value open_basedir /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/awl/inc:/etc/davical
+ php_value include_path /srv/http/davical/inc:/usr/share/awl/inc
+ php_value magic_quotes_gpc 0
+ php_value register_globals 0
+ php_value error_reporting "E_ALL & ~E_NOTICE"
+ php_value default_charset "utf-8"
+ php_value magic_quotes_runtime 0
+</Directory>
+
+<VirtualHost *:80>
+ DirectoryIndex index.php index.html
+ ServerAdmin webmaster@example.com
+ DocumentRoot "/srv/http/davical/htdocs"
+ Alias /images/ /srv/http/davical/htdocs/images/
+ AcceptPathInfo On
+ <Directory /srv/http/davical/htdocs/>
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ ServerName localhost
+ ServerAlias alias.localhost
+ php_value open_basedir /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/awl/inc:/etc/davical
+ php_value include_path /srv/http/davical/inc:/usr/share/awl/inc
+ php_value magic_quotes_gpc 0
+ php_value register_globals 0
+ php_value error_reporting "E_ALL & ~E_NOTICE"
+ php_value default_charset "utf-8"
+ php_value magic_quotes_runtime 0
+ ErrorLog "/var/log/httpd/httpd-davical-error_log"
+ CustomLog "/var/log/httpd/httpd-davical-access_log" common
+</VirtualHost>