summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex2019-01-26 00:00:59 +0100
committerAlex2019-01-26 00:00:59 +0100
commit009ea68f8c39fd597e873cf08c12a9536327120b (patch)
tree3a61a5f2e2587abe9fad61ec85515b3eed66ec34
parent7cf524bc13fc07f31bf3d5c31f1d128b32ccdb73 (diff)
downloadaur-009ea68f8c39fd597e873cf08c12a9536327120b.tar.gz
Switching to bsdtar
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 785e80f1f49b..74f39424cd86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,10 +2,12 @@ pkgbase = davinci-resolve
pkgdesc = Professional A/V post-production software suite from Blackmagic Design
pkgver = 15.2.3
pkgrel = 1
- url = https://www.blackmagicdesign.com/
+ url = https://www.blackmagicdesign.com/products/davinciresolve
install = davinci-resolve.install
- arch = x86_64
+ arch = any
license = Commercial
+ makedepends = libarchive
+ makedepends = xdg-user-dirs
depends = glu
depends = gtk2
depends = gstreamer
@@ -18,10 +20,8 @@ pkgbase = davinci-resolve
depends = qt5-base
depends = qt5-svg
depends = qt5-webkit
- depends = libisoburn
depends = qt5-webengine
depends = qt5-websockets
- depends = xdg-user-dirs
conflicts = davinci-resolve-beta
conflicts = davinci-resolve-studio
conflicts = davinci-resolve-studio-beta
diff --git a/PKGBUILD b/PKGBUILD
index a9753631f191..840b3d83f24e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
# You'll need to download the package archive from
-# https://www.blackmagicdesign.com/products/davinciresolve
+# https://www.blackmagicdesign.com/support/
# Hardware support is limited. Nvidia cards should work fine.
# If you're running a hybrid setup, try with primusrun/optirun.
@@ -13,15 +13,16 @@ resolve_app_name=com.blackmagicdesign.resolve
pkgver=15.2.3
pkgrel=1
pkgdesc='Professional A/V post-production software suite from Blackmagic Design'
-arch=('x86_64')
-url="https://www.blackmagicdesign.com/"
+arch=('any')
+url="https://www.blackmagicdesign.com/products/davinciresolve"
license=('Commercial')
depends=('glu' 'gtk2' 'gstreamer' 'libpng12' 'lib32-libpng12' 'ocl-icd' 'openssl-1.0'
- 'opencl-driver' 'qt4' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'libisoburn'
- 'qt5-webengine' 'qt5-websockets' 'xdg-user-dirs')
+ 'opencl-driver' 'qt4' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'qt5-webengine' 'qt5-websockets')
+makedepends=('libarchive' 'xdg-user-dirs')
options=('!strip')
conflicts=('davinci-resolve-beta' 'davinci-resolve-studio' 'davinci-resolve-studio-beta')
install=${pkgname}.install
+
# Trying to make the user's life easier ;o)
msg2 "Trying to fetch the archive file if available..."
DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
@@ -64,8 +65,9 @@ package()
mkdir -p "${pkgdir}/etc/xdg/menus"
msg2 "Extracting from bundle..."
+ msg "Please wait, this take a while"
cd "${srcdir}" || exit
- xorriso -osirrox on -indev DaVinci_Resolve_${pkgver}_Linux.run -extract / "${pkgdir}/opt/${_pkgname}"
+ bsdtar x -f DaVinci_Resolve_${pkgver}_Linux.run -C "${pkgdir}/opt/${_pkgname}"
msg2 "Add lib symlinks..."
cd "${pkgdir}/opt/${_pkgname}/" || exit