summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex2019-08-09 17:41:33 +0200
committerAlex2019-08-09 17:41:33 +0200
commit3b60ae8550f4a21af4769faf5c22636422806228 (patch)
treeb8b88889b0091a375898b8f9facb93ef7f0a42f2
parent10e2b1be34b557785744b9509b0523ff1ba02635 (diff)
downloadaur-3b60ae8550f4a21af4769faf5c22636422806228.tar.gz
Update to v16.0
-rw-r--r--.SRCINFO14
l---------DaVinci_Resolve_15.3.1_Linux.zip1
-rw-r--r--PKGBUILD47
-rw-r--r--PKGBUILD_NEW163
4 files changed, 40 insertions, 185 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 964e0e2e707f..43288336914b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = davinci-resolve
+pkgbase = davinci-resolve-beta
pkgdesc = Professional A/V post-production software suite from Blackmagic Design
- pkgver = 15.3.1
+ pkgver = 16.0
pkgrel = 1
url = https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion
install = davinci-resolve.install
@@ -16,18 +16,18 @@ pkgbase = davinci-resolve
depends = ocl-icd
depends = openssl-1.0
depends = opencl-driver
- depends = qt4
depends = qt5-base
depends = qt5-svg
depends = qt5-webkit
depends = qt5-webengine
depends = qt5-websockets
- conflicts = davinci-resolve-beta
+ provides = davinci-resolve
+ conflicts = davinci-resolve
conflicts = davinci-resolve-studio
conflicts = davinci-resolve-studio-beta
options = !strip
- source = local://DaVinci_Resolve_15.3.1_Linux.zip
- sha256sums = 6ac9a8b06c848567e9add85e086cb9d7ac4a4bb51da9805cb688c9461392aa9f
+ source = local://DaVinci_Resolve_16.0_Linux.zip
+ sha256sums = 03f7bbd32eb2956fd933838690af7e86ecc0eca9f935ef287cebdebaaf5a2dd2
-pkgname = davinci-resolve
+pkgname = davinci-resolve-beta
diff --git a/DaVinci_Resolve_15.3.1_Linux.zip b/DaVinci_Resolve_15.3.1_Linux.zip
deleted file mode 120000
index 23a0dbfdb722..000000000000
--- a/DaVinci_Resolve_15.3.1_Linux.zip
+++ /dev/null
@@ -1 +0,0 @@
-/home/alex/Downloads/DaVinci_Resolve_15.3.1_Linux.zip \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 1850064441c7..3fdffcbbed7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,39 +7,58 @@
# Hardware support is limited. Nvidia cards should work fine.
# If you're running a hybrid setup, try with primusrun/optirun.
-pkgname=davinci-resolve
+pkgname=davinci-resolve-beta
_pkgname=resolve
resolve_app_name=com.blackmagicdesign.resolve
-pkgver=15.3.1
+pkgver=16.0
pkgrel=1
-pkgdesc='Professional A/V post-production software suite from Blackmagic Design'
arch=('any')
url="https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion"
license=('Commercial')
depends=('glu' 'gtk2' 'gstreamer' 'libpng12' 'lib32-libpng12' 'ocl-icd' 'openssl-1.0'
- 'opencl-driver' 'qt4' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'qt5-webengine' 'qt5-websockets')
+ 'opencl-driver' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'qt5-webengine' 'qt5-websockets')
makedepends=('libarchive' 'xdg-user-dirs')
options=('!strip')
-conflicts=('davinci-resolve-beta' 'davinci-resolve-studio' 'davinci-resolve-studio-beta')
-install=${pkgname}.install
+provides=('davinci-resolve')
+install=davinci-resolve.install
+
+if [ ${pkgname} == "davinci-resolve-studio-beta" ]; then
+# Variables for STUDIO edition
+ pkgdesc='Professional A/V post-production software suite from Blackmagic Design. Studio edition, requires license key or license dongle.'
+ _archive_name=DaVinci_Resolve_Studio_${pkgver}_Linux
+ sha256sums=('03f7bbd32eb2956fd933838690af7e86ecc0eca9f935ef287cebdebaaf5a2dd2')
+ conflicts=('davinci-resolve-beta' 'davinci-resolve' 'davinci-resolve-studio')
+
+else
+# Variables for FREE edition
+ pkgdesc='Professional A/V post-production software suite from Blackmagic Design'
+ _archive_name=DaVinci_Resolve_${pkgver}_Linux
+ sha256sums=('03f7bbd32eb2956fd933838690af7e86ecc0eca9f935ef287cebdebaaf5a2dd2')
+ conflicts=('davinci-resolve' 'davinci-resolve-studio' 'davinci-resolve-studio-beta')
+
+fi
+
+
+_archive=${_archive_name}.zip
+_installer_binary=${_archive_name}.run
# Trying to make the user's life easier ;o)
msg2 "Trying to fetch the archive file if available..."
DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
-if [ ! -f ${PWD}/DaVinci_Resolve_${pkgver}_Linux.zip ]; then
- if [ -f $DOWNLOADS_DIR/DaVinci_Resolve_${pkgver}_Linux.zip ]; then
- ln -sfn $DOWNLOADS_DIR/DaVinci_Resolve_${pkgver}_Linux.zip ${PWD}
+if [ ! -f ${PWD}/${_archive} ]; then
+ if [ -f $DOWNLOADS_DIR/${_archive} ]; then
+ ln -sfn $DOWNLOADS_DIR/${_archive} ${PWD}
else
msg2 ""
msg2 "The package can be downloaded here: https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion"
- msg2 "Please remember to put a downloaded package DaVinci_Resolve_${pkgver}_Linux.zip into the build directory ${PWD} or $DOWNLOADS_DIR"
+ msg2 "Please remember to put a downloaded package ${_archive}into the build directory ${PWD} or $DOWNLOADS_DIR"
msg2 ""
fi
fi
-source=("local://DaVinci_Resolve_${pkgver}_Linux.zip")
-sha256sums=('6ac9a8b06c848567e9add85e086cb9d7ac4a4bb51da9805cb688c9461392aa9f')
+source=("local://${_archive}")
+
prepare()
{
@@ -66,7 +85,7 @@ package()
msg2 "Extracting from bundle..."
msg "Please wait, this take a while..."
cd "${srcdir}" || exit
- bsdtar x -f DaVinci_Resolve_${pkgver}_Linux.run -C "${pkgdir}/opt/${_pkgname}"
+ bsdtar x -f ${_installer_binary} -C "${pkgdir}/opt/${_pkgname}"
msg2 "Add lib symlinks..."
cd "${pkgdir}/opt/${_pkgname}/" || exit
@@ -75,7 +94,7 @@ package()
msg2 "Install launchers and configs..."
cd "${pkgdir}/opt/${_pkgname}/" || exit
- install -Dm666 share/default-config-linux.dat "${pkgdir}/opt/${_pkgname}/configs/config.dat"
+ install -Dm666 share/default-config.dat "${pkgdir}/opt/${_pkgname}/configs/config.dat"
install -Dm666 share/log-conf.xml "${pkgdir}/opt/${_pkgname}/configs/log-conf.xml"
install -Dm666 share/default_cm_config.bin "${pkgdir}/opt/${_pkgname}/DolbyVision/config.bin"
install -Dm644 share/DaVinciResolve.desktop "${pkgdir}/usr/share/applications/${resolve_app_name}.desktop"
diff --git a/PKGBUILD_NEW b/PKGBUILD_NEW
deleted file mode 100644
index 1746eaccff28..000000000000
--- a/PKGBUILD_NEW
+++ /dev/null
@@ -1,163 +0,0 @@
-# Maintainer: Alex S. <shantanna_at_hotmail_dot_com>
-# Contributor: Jonathon Fernyhough <jonathon_at_manjaro_dot_org>
-
-# You'll need to download the package archive from
-# https://www.blackmagicdesign.com/support/
-
-# Hardware support is limited. Nvidia cards should work fine.
-# If you're running a hybrid setup, try with primusrun/optirun.
-
-pkgname=davinci-resolve
-_pkgname=resolve
-resolve_app_name=com.blackmagicdesign.resolve
-pkgver=15.2.3
-pkgrel=1
-pkgdesc='Professional A/V post-production software suite from Blackmagic Design'
-arch=('any')
-url="https://www.blackmagicdesign.com/products/davinciresolve"
-license=('Commercial')
-depends=('glu' 'gtk2' 'gstreamer' 'libpng12' 'lib32-libpng12' 'ocl-icd' 'openssl-1.0'
- 'opencl-driver' 'qt4' 'qt5-base' 'qt5-svg' 'qt5-webkit' 'qt5-webengine' 'qt5-websockets')
-makedepends=('libarchive' 'xdg-user-dirs')
-options=('!strip')
-conflicts=('davinci-resolve-beta' 'davinci-resolve-studio' 'davinci-resolve-studio-beta')
-install=${pkgname}.install
-
-# Trying to make the user's life easier ;o)
-_downloadid='24a482e1e9154ef793aa71e5d3b3a391'
-_referid='b9f352753ebe4cc5a74005e2d053263c'
-_srcurl="https://www.blackmagicdesign.com/api/register/us/download/${_downloadid}"
-
-source=("DaVinci_Resolve_${pkgver}_Linux.zip"::"$_srcurl")
-sha256sums=('d0123739c68b3b03565a1478625a3ebafbb067eb5631a7c7b0a41726f5d5c854')
-
-_useragent="User-Agent: Mozilla/5.0 (X11; Linux ${CARCH}) \
- AppleWebKit/537.36 (KHTML, like Gecko) \
- Chrome/70.0.3538.77 \
- Safari/537.36"
-
-_reqjson="{ \
- \"platform\": \"Linux\", \
- \"country\": \"us\", \
- \"firstname\": \"Arch\", \
- \"lastname\": \"Linux\", \
- \"email\": \"someone@archlinux.org\", \
- \"phone\": \"202-555-0194\", \
- \"state\": \"New York\", \
- \"city\": \"AUR\", \
- \"product\": \"DaVinci Resolve ${pkgver}\" \
-}"
-
-_reqjson="$( printf '%s' "$_reqjson" | sed 's/[[:space:]]\+/ /g')"
-_useragent="$(printf '%s' "$_useragent" | sed 's/[[:space:]]\+/ /g')"
-_useragent_escaped="${_useragent// /\\ }"
-
-DLAGENTS=("https::/usr/bin/curl \
- -gqb '' -C - --retry 3 --retry-delay 3 \
- -H Host:\ sw.blackmagicdesign.com \
- -H Upgrade-Insecure-Requests:\ 1 \
- -H ${_useragent_escaped} \
- -H Accept:\ text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8 \
- -H Accept-Language:\ en-US,en;q=0.9 \
- -o %o \
- --compressed \
- $(curl \
- -s \
- -H 'Host: www.blackmagicdesign.com' \
- -H 'Accept: application/json, text/plain, */*' \
- -H 'Origin: https://www.blackmagicdesign.com' \
- -H "$_useragent" \
- -H 'Content-Type: application/json;charset=UTF-8' \
- -H "Referer: https://www.blackmagicdesign.com/support/download/${_referid}/Linux" \
- -H 'Accept-Encoding: gzip, deflate, br' \
- -H 'Accept-Language: en-US,en;q=0.9' \
- -H 'Authority: www.blackmagicdesign.com' \
- -H 'Cookie: _ga=GA1.2.1849503966.1518103294; _gid=GA1.2.953840595.1518103294' \
- --data-binary "$_reqjson" \
- --compressed \
- "$_srcurl"
- )"
-)
-
-prepare()
-{
- # Remove udev rules (The official installer does not remove these files. This leads to the conflict "exists in the file system".)
- confiles=$(find /usr/lib/udev/rules.d -name 75-davincipanel.rules -o -name 75-sdx.rules 2> /dev/null | awk -F/ '{print $NF}'
- find /opt/resolve/configs -name log-conf.xml -o -name config.dat 2> /dev/null | awk -F/ '{print $NF}'
- )
- if [ "${confiles}" ]; then
- msg2 "The file(s) $(echo ${confiles} | xargs | sed 's/ /, /g') already exist in your filesystem."
- msg2 "This can lead to a conflict and the installation will fail."
- msg2 "Please restart the installation with the --overwrite option."
- fi
-}
-
-package()
-{
- msg2 "Creating missing folders..."
- mkdir -p -m 0775 "${pkgdir}/opt/${_pkgname}/"{configs,DolbyVision,easyDCP,Fairlight,GPUCache,logs,Media,"Resolve Disk Database",.crashreport,.license,.LUT}
- mkdir -p "${pkgdir}/usr/share/"{applications,desktop-directories,icons/hicolor,mime/packages}
-# mkdir -p "${pkgdir}/tmp/${_pkgname}/"{logs,GPUCache}
- mkdir -p "${pkgdir}/usr/lib/udev/rules.d"
- mkdir -p "${pkgdir}/etc/xdg/menus"
-
- msg2 "Extracting from bundle..."
- cd "${srcdir}" || exit
- bsdtar x -f DaVinci_Resolve_${pkgver}_Linux.run -C "${pkgdir}/opt/${_pkgname}"
-
- msg2 "Add lib symlinks..."
- cd "${pkgdir}/opt/${_pkgname}/" || exit
- ln -s /usr/lib/libcrypto.so.1.0.0 libs/libcrypto.so.10
- ln -s /usr/lib/libssl.so.1.0.0 libs/libssl.so.10
-
- msg2 "Install launchers and configs..."
- cd "${pkgdir}/opt/${_pkgname}/" || exit
- install -Dm666 share/default-config-linux.dat "${pkgdir}/opt/${_pkgname}/configs/config.dat"
- install -Dm666 share/log-conf.xml "${pkgdir}/opt/${_pkgname}/configs/log-conf.xml"
- install -Dm666 share/default_cm_config.bin "${pkgdir}/opt/${_pkgname}/DolbyVision/config.bin"
- install -Dm644 share/DaVinciResolve.desktop "${pkgdir}/usr/share/applications/${resolve_app_name}.desktop"
- install -Dm644 share/DaVinciResolvePanelSetup.desktop "${pkgdir}/usr/share/applications/${resolve_app_name}-Panels.desktop"
- install -Dm644 share/DaVinciResolveInstaller.desktop "${pkgdir}/usr/share/applications/${resolve_app_name}-Installer.desktop"
- install -Dm644 share/DaVinciResolveCaptureLogs.desktop "${pkgdir}/usr/share/applications/${resolve_app_name}-CaptureLogs.desktop"
- install -Dm644 share/DaVinciResolve.directory "${pkgdir}/usr/share/desktop-directories/${resolve_app_name}.directory"
- install -Dm644 share/DaVinciResolve.menu "${pkgdir}/etc/xdg/menus/${resolve_app_name}.menu"
-
- for _file in $(find ${pkgdir}/usr/share ${pkgdir}/etc -type f -name *.desktop -o -name *.directory -o -name *.menu | xargs)
- do
- sed -i "s|RESOLVE_INSTALL_LOCATION|/opt/${_pkgname}|g" $_file
- done
-
- # This will help adding the app to favorites and prevent glitches on many desktops.
- echo "StartupWMClass=resolve" >> "${pkgdir}/usr/share/applications/${resolve_app_name}.desktop"
-
- msg2 "Creating and installing udev rules..."
- echo 'SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="096e", MODE="0666"' > "${pkgdir}/usr/lib/udev/rules.d/75-davincipanel.rules"
- echo 'SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="1edb", MODE="0666"' > "${pkgdir}/usr/lib/udev/rules.d/75-sdx.rules"
- chmod 644 "${pkgdir}/usr/lib/udev/rules.d/"{75-davincipanel.rules,75-sdx.rules}
-
-# Not sure we need it
-# msg2 "Any final tweaks..."
-# ln -s "/tmp/${_pkgname}/logs" "${pkgdir}/opt/${_pkgname}/logs"
-# ln -s "/tmp/${_pkgname}/GPUCache" "${pkgdir}/opt/${_pkgname}/GPUCache"
-
- msg2 "Installing Application icons..."
- # Obviously not working without root rights.
-# XDG_DATA_DIRS="${pkgdir}/usr/share/icons/hicolor" xdg-icon-resource install --size 64 "${pkgdir}/opt/${_pkgname}/graphics/DV_Resolve.png" DaVinci-Resolve 2>&1 >> /dev/null
-# XDG_DATA_DIRS="${pkgdir}/usr/share/icons/hicolor" xdg-icon-resource install --size 64 "${pkgdir}/opt/${_pkgname}/graphics/DV_ResolveProj.png" DaVinci-ResolveProj 2>&1 >> /dev/null
-# XDG_DATA_DIRS="${pkgdir}/usr/share/icons/hicolor" xdg-icon-resource install --size 64 --context mimetypes "${pkgdir}/opt/${_pkgname}/graphics/DV_ResolveProj.png" application-x-resolveproj 2>&1 >> /dev/null
-# XDG_DATA_DIRS="${pkgdir}/usr/share/mime/packages" xdg-mime install --novendor "${pkgdir}/opt/${_pkgname}/share/resolve.xml" 2>&1 >> /dev/null
- install -D -m644 graphics/DV_Resolve.png "${pkgdir}/usr/share/icons/hicolor/64x64/apps/DV_Resolve.png"
- install -D -m644 graphics/DV_ResolveProj.png "${pkgdir}/usr/share/icons/hicolor/64x64/apps/DV_ResolveProj.png"
-
- install -D -m644 share/resolve.xml "${pkgdir}/usr/share/mime/packages/resolve.xml"
-
- msg2 "Setting the right permissions..."
- _user=$(logname)
- _group=$(id -g -n ${_user})
- chown -R ${_user}:${_group} "${pkgdir}/opt/${_pkgname}/"{*,.*}
- chown -R ${_user}:root "${pkgdir}/opt/${_pkgname}/"{configs,DolbyVision,easyDCP,Fairlight,logs,Media,'Resolve Disk Database',.crashreport,.license,.LUT}
-
- msg2 "Done!"
-}
-
-# vim: fileencoding=utf-8 sts=4 sw=4 noet