summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodibit2018-10-25 13:17:52 +0200
committercodibit2018-10-25 13:17:52 +0200
commit97f3c987d06734b313bac9c961485d0ff835031d (patch)
treef93a371082f413b0b1bea11f74aeac4bdb733ec5
parentd8950c4d48bab36932c6e5c74b7196425acffd8a (diff)
downloadaur-97f3c987d06734b313bac9c961485d0ff835031d.tar.gz
opied new file handling from the davinci-resolve package to use xdg-dirs
Removed most msg2's, as it's not recommended to print so many mesages. Added a post-install script to remind the user to run the app as root. Updated README.md
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD53
-rw-r--r--README.md39
-rw-r--r--davinci-resolve-studio.install5
4 files changed, 48 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7103fe4ec5c..0eafdf63175a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = davinci-resolve-studio
pkgdesc = Professional A/V post-production software suite
- pkgver = 14.3
- pkgrel = 1
+ pkgver = 15.1.2
+ pkgrel = 0
url = https://www.blackmagicdesign.com/
+ install = davinci-resolve-studio.install
arch = x86_64
license = Commercial
depends = glu
@@ -19,10 +20,16 @@ pkgbase = davinci-resolve-studio
depends = qt5-webkit
depends = qt5-webengine
depends = qt5-websockets
+ depends = xdg-user-dirs
+ depends = unzip
+ conflicts = davinci-resolve-beta
conflicts = davinci-resolve
+ conflicts = davinci-resolve-studio-beta
options = !strip
- source = local://DaVinci_Resolve_Studio_14.3_Linux.zip
- sha256sums = c13df388f0405dd120ae247e5ea3406dc6dcbef64e32ae3c7c0f37cc0ae6db23
+ source = local://DaVinci_Resolve_Studio_15.1.2_Linux.zip
+ source = davinci-resolve-studio.install
+ sha256sums = 3599569e0403131f13a5b7fa7237669b071f0ba80253e0b04b89c94ede62277a
+ sha256sums = ff105552fc59e7957e1d9ed19f4c4d41294459353e3525f57207ed43e882b508
pkgname = davinci-resolve-studio
diff --git a/PKGBUILD b/PKGBUILD
index 924b9bda7fb4..64e81215d80d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,29 +10,33 @@
pkgname=davinci-resolve-studio
_pkgname=resolve
-pkgver=14.3
-pkgrel=1
+pkgver=15.1.2
+pkgrel=0
pkgdesc='Professional A/V post-production software suite'
arch=('x86_64')
url="https://www.blackmagicdesign.com/"
license=('Commercial')
depends=('glu' 'gtk2' 'gstreamer' 'libpng12' 'lib32-libpng12' 'ocl-icd' 'openssl-1.0'
'opencl-driver' 'qt4' 'qt5-base' 'qt5-svg' 'qt5-webkit'
- 'qt5-webengine' 'qt5-websockets')
-conflicts=('davinci-resolve')
+ 'qt5-webengine' 'qt5-websockets' 'xdg-user-dirs' 'unzip')
options=('!strip')
+conflicts=('davinci-resolve-beta' 'davinci-resolve' 'davinci-resolve-studio-beta')
+install='davinci-resolve-studio.install'
+
+DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
if [ ! -f ${pkgdir}/DaVinci_Resolve_Studio_${pkgver}_Linux.zip ]; then
- if [ -f $HOME/Downloads/DaVinci_Resolve_Studio_${pkgver}_Linux.zip ]; then
- ln -sf $HOME/Downloads/DaVinci_Resolve_Studio_${pkgver}_Linux.zip ${pkgdir}
+ if [ -f $DOWNLOADS_DIR/DaVinci_Resolve_Studio_${pkgver}_Linux.zip ]; then
+ ln -sfn $DOWNLOADS_DIR/DaVinci_Resolve_Studio_${pkgver}_Linux.zip ${pkgdir}
else
- msg2 "Please remember to put a package archive DaVinci_Resolve_Studio_${pkgver}_Linux.zip in your Downloads directory"
+ msg2 "The package can be downloaded here: https://www.blackmagicdesign.com/products/davinciresolve/"
+ error "DaVinci_Resolve_${pkgver}_Linux.zip not found in the build directory or $DOWNLOADS_DIR"
sleep 3
fi
fi
-source=("local://DaVinci_Resolve_Studio_${pkgver}_Linux.zip")
-sha256sums=('c13df388f0405dd120ae247e5ea3406dc6dcbef64e32ae3c7c0f37cc0ae6db23')
+source=("local://DaVinci_Resolve_Studio_${pkgver}_Linux.zip" "davinci-resolve-studio.install")
+sha256sums=('3599569e0403131f13a5b7fa7237669b071f0ba80253e0b04b89c94ede62277a' 'ff105552fc59e7957e1d9ed19f4c4d41294459353e3525f57207ed43e882b508')
package() {
@@ -40,11 +44,11 @@ package() {
# msg2 "Did you download the archive manually? If not, this will fail."
mkdir -p "${pkgdir}/opt/${_pkgname}/"{bin,configs,Media}
- msg2 "Extracting from bundle..."
+# msg2 "Extracting from bundle..."
cd "${srcdir}" || exit
./DaVinci_Resolve_Studio_${pkgver}_Linux.sh --tar xf -C "${pkgdir}/opt/${_pkgname}"
- msg2 "Extracting library archives..."
+# msg2 "Extracting library archives..."
cd "${pkgdir}/opt/${_pkgname}/" || exit
gunzip -f LUT/trim_lut0.dpx.gz
for archive in libs/*tgz; do
@@ -52,7 +56,7 @@ package() {
rm -f "${archive}"
done
- msg2 "Relocate binaries and config..."
+# msg2 "Relocate binaries and config..."
cd "${pkgdir}/opt/${_pkgname}/" || exit
local _binaries=(
BMDPanelFirmware
@@ -73,23 +77,30 @@ package() {
mv rsf/Control Control
install -Dm666 rsf/default-config-linux.dat "${pkgdir}/opt/${_pkgname}/configs/config.dat"
- msg2 "Add lib symlinks..."
+# msg2 "Add lib symlinks..."
cd "${pkgdir}/opt/${_pkgname}/" || exit
ln -s /usr/lib/libcrypto.so.1.0.0 libs/libcrypto.so.10
ln -s /usr/lib/libssl.so.1.0.0 libs/libssl.so.10
ln -s /usr/lib/libgstbase-1.0.so libs/libgstbase-0.10.so.0
ln -s /usr/lib/libgstreamer-1.0.so libs/libgstreamer-0.10.so.0
-
- msg2 "Creating udev rules"
+
+# Fusion templates need to be extracted in /opt/resolve, thx @laemplein
+# msg2 "Extracting Fusion templates"
+ unzip -q "${pkgdir}/opt/${_pkgname}/rsf/fusion_presets.zip" -d "${pkgdir}/opt/${_pkgname}/"
+
+# msg2 "Creating udev rules for dongles"
# Ensure dongle permissions are correctly set
SDX_RULES="${srcdir}/75-sdx.rules"
echo 'SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="096e", MODE="0666"' > ${SDX_RULES}
-
install -Dm644 ${SDX_RULES} "${pkgdir}/usr/lib/udev/rules.d/75-sdx.rules"
+
+# Remind the user to open resolve as root for activation if not using a dongle, thx @alxjsn & @macman for pointing this out
+# msg2 "Remember to open Davinci Resolve Studio for activation if you have an activation code"
- msg2 "Creating launchers..."
+# msg2 "Creating launchers..."
cd "${srcdir}" || exit
cat > "${srcdir}/DaVinci Resolve Studio.desktop" << EOF
+
#!/usr/bin/env xdg-open
[Desktop Entry]
Type=Application
@@ -100,7 +111,7 @@ Icon=/opt/${_pkgname}/rsf/DV_Resolve.png
Terminal=false
Categories=Multimedia;AudioVideo;Application;
EOF
- install -Dm644 DaVinci\ Resolve\ Studio.desktop "${pkgdir}/usr/share/applications/DaVinci Resolve\ Studio.desktop"
+ install -Dm644 DaVinci\ Resolve\ Studio.desktop "${pkgdir}/usr/share/applications/DaVinci Resolve Studio.desktop"
cat > "${srcdir}/start-resolve" << EOF
#!/bin/sh
@@ -110,16 +121,16 @@ exec bin/resolve "\$@"
EOF
install -Dm755 start-resolve "${pkgdir}/opt/${_pkgname}/bin/start-resolve"
- msg2 "Making sure file ownership is 'correct'..."
+# msg2 "Making sure file ownership is 'correct'..."
chown -R root:root "${pkgdir}/opt"
chmod 0777 "${pkgdir}/opt/${_pkgname}/configs"
chmod 0777 "${pkgdir}/opt/${_pkgname}/Media"
- msg2 "Any final tweaks..."
+# msg2 "Any final tweaks..."
ln -s "/tmp/${_pkgname}/logs" "${pkgdir}/opt/${_pkgname}/logs"
ln -s "/tmp/${_pkgname}/GPUCache" "${pkgdir}/opt/${_pkgname}/GPUCache"
- msg2 "Done!"
+# msg2 "Done!"
}
# vim: fileencoding=utf-8 sts=4 sw=4 noet
diff --git a/README.md b/README.md
deleted file mode 100644
index 36d5a0e457a3..000000000000
--- a/README.md
+++ /dev/null
@@ -1,39 +0,0 @@
-# davinci-resolve-studio for Arch Linux
-Archlinux Package to install Blackmagic's Davinci Resolve Studio, based on https://aur.archlinux.org/packages/davinci-resolve/
-
-This package adds the package name and sha256 from the studio version zip file, and also adds an udev rule for the dongle. Please let me know of any [issues here](https://github.com/codibit/davinci-resolve-studio/issues).
-## INSTALLATION:
-
-To install, simply download the Davinci Resolve Studio installer from [Blackmagic's
-website](https://www.blackmagicdesign.com/products/davinciresolve/) to your Downloads directory. The DaVinci_Resolve_Studio_X.Y.Z_Linux.zip
-file (where X.Y.Z is te current package version) should be placed into /home/$youruser/Downloads or inside the package directory.
-
-### Automatic installation:
-You should be able to automatically install from the AUR repository with a tool like [yaourt](https://archlinux.fr/yaourt-en):
-
-`yaourt davinci-resolve-studio`
-
-### Manual installation:
-* If you want to manually install, clone this repository from [GitHub](https://github.com/codibit/davinci-resolve-studio) _or_ [AUR](https://aur.archlinux.org/packages/davinci-resolve-studio/):
-
-`git clone https://github.com/codibit/davinci-resolve-studio.git`
-
-_or_
-
-`git clone https://aur.archlinux.org/davinci-resolve-studio.git`
-
-* run makepkg inside the directory (as your regular user):
-
-`cd davinci-resolve-studio`
-
-`makepkg`
-
-* and finally install the created package with pacman (as root):
-
-`pacman -U davinci-resolve-studio-X.Y.Z-0-x86_64.pkg.tar.xz`
-
-## TODO:
-I don't use BlackMagic's panels, so I didn't bother to add the BMDPanel support drivers & daemon. If someone could test it, I might add it to the package.
-
-## CREDITS:
-All the package credits go to the [davinci-resolve](https://aur.archlinux.org/packages/davinci-resolve/) package mantainer and contribuitors in [https://aur.archlinux.org/packages/davinci-resolve/](https://aur.archlinux.org/packages/davinci-resolve/)
diff --git a/davinci-resolve-studio.install b/davinci-resolve-studio.install
new file mode 100644
index 000000000000..e478eeb87cbb
--- /dev/null
+++ b/davinci-resolve-studio.install
@@ -0,0 +1,5 @@
+post_install() {
+ tput bold
+ echo "Remember to open Davinci Resolve Studio as root for activation if you have an activation code instead of a dongle"
+ tput sgr0
+} \ No newline at end of file