summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-17 12:19:51 +0000
committerDaniel Bermond2018-11-17 12:19:51 +0000
commit39a20901c52b19b2d0d0fd46062c2abecc3b67b3 (patch)
tree4f4d4b59b45c2cc771b42eecc3ea0b0148e17c34
parent47c9004d7babdd7355b1e2024c5f436d381c75a5 (diff)
downloadaur-39a20901c52b19b2d0d0fd46062c2abecc3b67b3.tar.gz
Match upstream changes. Do not copy source tree for 8-bit only.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01950b66b212..ce6cbebd7ace 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = davs2-git
pkgdesc = Open-Source decoder of AVS2-P2/IEEE1857.4 video coding standard (git version)
- pkgver = 1.0.r139.gd997b79
- pkgrel = 2
+ pkgver = 1.6.r0.gef9a901
+ pkgrel = 1
url = https://github.com/pkuvcl/davs2/
arch = i686
arch = x86_64
@@ -9,9 +9,7 @@ pkgbase = davs2-git
makedepends = git
makedepends = gcc7
makedepends = yasm
- makedepends = l-smash
depends = glibc
- depends = liblsmash.so
provides = davs2
provides = libdavs2-git
conflicts = davs2
diff --git a/PKGBUILD b/PKGBUILD
index d4ea16b5f374..7d525ff9216d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
pkgname=davs2-git
_srcname=davs2
-pkgver=1.0.r139.gd997b79
-pkgrel=2
+pkgver=1.6.r0.gef9a901
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Open-Source decoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
url='https://github.com/pkuvcl/davs2/'
license=('GPL')
-depends=('glibc' 'liblsmash.so')
-makedepends=('git' 'gcc7' 'yasm' 'l-smash')
+depends=('glibc')
+makedepends=('git' 'gcc7' 'yasm')
provides=('davs2' 'libdavs2-git')
conflicts=('davs2' 'libdavs2-git')
replaces=('libdavs2-git')
@@ -25,10 +25,6 @@ prepare() {
# use gcc7 (it does not build with gcc8)
sed -i 's/g++/g++-7/' build/linux/configure
-
- # must copy the entire source tree or it will not work
- cd "$srcdir"
- cp -af "$_srcname" build-8bit
}
pkgver() {
@@ -39,23 +35,20 @@ pkgver() {
}
build() {
- cd build-8bit/build/linux
+ cd "${_srcname}/build/linux"
./configure \
--prefix='/usr' \
--enable-shared \
+ --disable-static \
--bit-depth='8' \
--chroma-format='all' \
--enable-lto \
- --enable-pic \
- --disable-swscale \
- --disable-lavf \
- --disable-ffms \
- --disable-gpac
+ --enable-pic
make
}
package() {
- make -C build-8bit/build/linux DESTDIR="$pkgdir" install-cli install-lib-shared
+ make -C "${_srcname}/build/linux" DESTDIR="$pkgdir" install-cli install-lib-shared
}