summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-09 22:30:54 +0000
committerDaniel Bermond2018-11-09 22:31:01 +0000
commit47c9004d7babdd7355b1e2024c5f436d381c75a5 (patch)
treeb7503526e8fd4b3e45609c43e7be1dbb3439070b
parenta4e0274ed98eacf84aa8034ab703a4d7e66b4218 (diff)
downloadaur-47c9004d7babdd7355b1e2024c5f436d381c75a5.tar.gz
Do not rename the source clone
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cb839bba0cf..01950b66b212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = davs2-git
pkgdesc = Open-Source decoder of AVS2-P2/IEEE1857.4 video coding standard (git version)
pkgver = 1.0.r139.gd997b79
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pkuvcl/davs2/
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = davs2-git
conflicts = davs2
conflicts = libdavs2-git
replaces = libdavs2-git
- source = davs2-git::git+https://github.com/pkuvcl/davs2.git
+ source = git+https://github.com/pkuvcl/davs2.git
sha256sums = SKIP
pkgname = davs2-git
diff --git a/PKGBUILD b/PKGBUILD
index 544c1f31168a..d4ea16b5f374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@
# https://github.com/pkuvcl/davs2/issues/4
pkgname=davs2-git
+_srcname=davs2
pkgver=1.0.r139.gd997b79
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='Open-Source decoder of AVS2-P2/IEEE1857.4 video coding standard (git version)'
url='https://github.com/pkuvcl/davs2/'
@@ -16,22 +17,22 @@ makedepends=('git' 'gcc7' 'yasm' 'l-smash')
provides=('davs2' 'libdavs2-git')
conflicts=('davs2' 'libdavs2-git')
replaces=('libdavs2-git')
-source=("$pkgname"::'git+https://github.com/pkuvcl/davs2.git')
+source=('git+https://github.com/pkuvcl/davs2.git')
sha256sums=('SKIP')
prepare() {
- cd "$pkgname"
+ cd "$_srcname"
# use gcc7 (it does not build with gcc8)
sed -i 's/g++/g++-7/' build/linux/configure
# must copy the entire source tree or it will not work
cd "$srcdir"
- cp -af "$pkgname" build-8bit
+ cp -af "$_srcname" build-8bit
}
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'