summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:37:13 +0200
committerL.G. Sarmiento2015-06-14 19:37:13 +0200
commitfe25603e826d1cc7bd185a062d4cc4ba4325f1d1 (patch)
tree8177acab400f44a7317bd1f56fef58930d88ecde
downloadaur-fe25603e826d1cc7bd185a062d4cc4ba4325f1d1.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD59
-rw-r--r--dawn-3.90b-no-interactive.patch43
-rw-r--r--make_DESTDIR.patch11
4 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06c058b5e973
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dawn
+ pkgdesc = 3D geometrical postscript renderer
+ pkgver = 3.90b
+ pkgrel = 3
+ url = http://geant4.kek.jp/~tanaka/DAWN/About_DAWN.html
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = texlive-core
+ depends = tcsh
+ depends = tk
+ depends = libx11
+ depends = gv
+ source = http://geant4.kek.jp/~tanaka/src/dawn_3_90b.tgz
+ source = dawn-3.90b-no-interactive.patch
+ source = make_DESTDIR.patch
+ md5sums = 3017f35db5c1ba7f7e95bff6f2d8bd46
+ md5sums = 7bb06c81f2f1ac5475939a40dd7cbc80
+ md5sums = 4128a7eb7ea6395e754cc3a02259425e
+
+pkgname = dawn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8748ff8bec26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Luis Sarmiento <lgsarmientop-ala-unal.edu.co>
+
+pkgname=dawn
+_PKGNAME=Dawn
+pkgver=3.90b
+_pkgver=3_90b
+pkgrel=3
+pkgdesc="3D geometrical postscript renderer"
+url="http://geant4.kek.jp/~tanaka/DAWN/About_DAWN.html"
+license=("unknown")
+arch=('i686' 'x86_64')
+makedepends=('texlive-core')
+depends=('tcsh' 'tk' 'libx11' 'gv')
+
+source=("http://geant4.kek.jp/~tanaka/src/${pkgname}_${_pkgver}.tgz"
+ "${pkgname}-${pkgver}-no-interactive.patch"
+ "make_DESTDIR.patch"
+ )
+
+md5sums=('3017f35db5c1ba7f7e95bff6f2d8bd46'
+ '7bb06c81f2f1ac5475939a40dd7cbc80'
+ '4128a7eb7ea6395e754cc3a02259425e')
+
+build () {
+ cd $srcdir/${pkgname}_${_pkgver}
+ patch -Np2 < ${srcdir}/${pkgname}-${pkgver}-no-interactive.patch
+ sed -i -e '/strip/d' Makefile*in
+
+ make clean && make guiclean
+ ./configure
+ make
+}
+
+package() {
+ cd $srcdir/${pkgname}_${_pkgver}
+ patch -Np2 < ${srcdir}/make_DESTDIR.patch
+ [ -d ${pkgdir}/usr/bin ] || install -d ${pkgdir}/usr/bin
+ make DESTDIR=${pkgdir} install
+
+ DOCDIR=usr/share/doc/${pkgname}
+ [ -d ${pkgdir}/${DOCDIR} ] || install -d ${pkgdir}/${DOCDIR}
+ cd ${srcdir}/${pkgname}_${_pkgver}
+ pdflatex DOC/G4PRIM_FORMAT_24.tex
+ install -m644 DOC/*.pdf ${pkgdir}/${DOCDIR}
+ install -m644 DOC/*.html ${pkgdir}/${DOCDIR}
+
+ echo "
+ [Desktop Entry]
+ Name=${_PKGNAME}
+ Comment=${pkgdesc}
+ Exec=${pkgname}
+ Icon=xchm-32
+ Terminal=false
+ Type=Application
+ Categories=Utility;Science;
+ StartupNotify=false
+ " > $srcdir/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+}
diff --git a/dawn-3.90b-no-interactive.patch b/dawn-3.90b-no-interactive.patch
new file mode 100644
index 000000000000..2466969632b8
--- /dev/null
+++ b/dawn-3.90b-no-interactive.patch
@@ -0,0 +1,43 @@
+--- configure 2010-08-21 08:22:18.000000000 -0500
++++ ../../configure 2012-02-02 11:48:23.000000000 -0500
+@@ -11,24 +11,28 @@
+
+ ##### INPUT #####
+ #----- C++ compiler name
+-echo "Input C++ compiler name (e.g. g++, no default)."
+-echo -n " :"
+-set cpp_compiler=$<
++#echo "Input C++ compiler name (e.g. g++, no default)."
++#echo -n " :"
++set cpp_compiler=g++
++#echo ""
+
+ #----- Optimization option of the C++ compiler
+-echo "Input optimization option (e.g. -O2, no default)"
+-echo -n " :"
+-set optimize=$<
++#echo "Input optimization option (e.g. -O2, no default)"
++#echo -n " :"
++set optimize=-O2
++#echo ""
+
+ #----- Input Tcl/Tk window shell name
+-echo "Input Tcl/Tk window shell name"
+-echo -n " (e.g. wish, no default): "
+-set wish=$<
++#echo "Input Tcl/Tk window shell name"
++#echo -n " (e.g. wish, no default): "
++set wish=wish
++#echo ""
+
+ #----- Input directory name to install dawn and DAWN_GUI
+-echo "Input directory to install executable files"
+-echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++#echo "Input directory to install executable files"
++#echo -n " (e.g. /usr/local/bin, no default ): "
++set install_dir=/usr/bin
++#echo ""
+
+
+ ##### DELETE #####
diff --git a/make_DESTDIR.patch b/make_DESTDIR.patch
new file mode 100644
index 000000000000..665e1013415e
--- /dev/null
+++ b/make_DESTDIR.patch
@@ -0,0 +1,11 @@
+--- Makefile 2012-02-02 11:49:43.000000000 -0500
++++ ../../Makefile 2012-02-02 11:50:42.000000000 -0500
+@@ -14,7 +14,7 @@
+ WISH = wish
+
+ ### Directory where to install executable files
+-INSTALL_DIR = /usr/bin
++INSTALL_DIR = $(DESTDIR)/usr/bin
+
+
+