summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Hensel2022-10-25 18:38:03 +0200
committerJan Hensel2022-10-25 18:38:03 +0200
commit6cc96514b1dd7a51aa82f35789956ab2be1c51d4 (patch)
tree537ebfc5e09e4d29ff546cc17ed5daa562b11d33
parentbd599af76fa7bf259edabad13e3a33db759ccec2 (diff)
downloadaur-6cc96514b1dd7a51aa82f35789956ab2be1c51d4.tar.gz
v0.7.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9da430c8a519..6310147cbcda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = dayplan
pkgdesc = Utility to plan your day and track your time
- pkgver = 0.7.2
+ pkgver = 0.7.4
pkgrel = 1
url = https://github.com/ja-he/dayplan
arch = x86_64
license = MIT
makedepends = go
depends = glibc
- source = dayplan-0.7.2.tar.gz::https://github.com/ja-he/dayplan/archive/v0.7.2.tar.gz
- sha256sums = 0b4179d8a6028a24954d30b471217af5d12da0ecd385304db52191f04d3bbfc9
+ source = dayplan-0.7.4.tar.gz::https://github.com/ja-he/dayplan/archive/v0.7.4.tar.gz
+ sha256sums = 4c5f62d3315291c9128041e91998361e0b3af95462a1431532839d7ff97528f5
pkgname = dayplan
diff --git a/PKGBUILD b/PKGBUILD
index 8cdbc38a441f..40768d1591a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jan Hensel <ja_he@uni-bremen.de>
pkgname=dayplan
-pkgver=0.7.2
+pkgver=0.7.4
pkgrel=1
arch=('x86_64')
pkgdesc="Utility to plan your day and track your time"
@@ -11,7 +11,7 @@ makedepends=('go')
optdepends=()
backup=()
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('0b4179d8a6028a24954d30b471217af5d12da0ecd385304db52191f04d3bbfc9')
+sha256sums=('4c5f62d3315291c9128041e91998361e0b3af95462a1431532839d7ff97528f5')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -21,7 +21,8 @@ build() {
-gcflags "all=-trimpath=${PWD}" \
-asmflags "all=-trimpath=${PWD}" \
-ldflags="-X '${source_root}/control/cli.version=v${pkgver}' -X '${source_root}/control/cli.hash=aur build from v${pkgver}'" \
- -buildmode=pie
+ -buildmode=pie \
+ cmd/dayplan.go
}
package() {