summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2016-03-27 01:00:52 -0700
committerAmmon Smith2016-03-27 01:00:52 -0700
commit5448f50e6a9ff696e77e9d30537cafff293de097 (patch)
tree2d0eabb30656a75650fdfbaba7b5fdc764497f75
downloadaur-5448f50e6a9ff696e77e9d30537cafff293de097.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1207256a5d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Mar 27 08:00:42 UTC 2016
+pkgbase = days-until-git
+ pkgdesc = A command-line program to give you the number of days until or since certain events.
+ pkgver = 0.1.3e97ed8
+ pkgrel = 1
+ url = https://gitlab.com/ammongit/days-until
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = python
+ provides = days-until
+ conflicts = days-until
+ source = git+https://gitlab.com/ammongit/days-until.git
+ sha256sums = SKIP
+
+pkgname = days-until-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40ca28762782
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+
+_pkgname='days-until'
+pkgname=$_pkgname-git
+pkgver=0.1.3e97ed8
+pkgrel=1
+pkgdesc='A command-line program to give you the number of days until or since certain events.'
+arch=('any')
+url="https://gitlab.com/ammongit/$_pkgname"
+license=('GPL2')
+depends=('python')
+makedepends=('git')
+optdepends=()
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+options=()
+source=("git+https://gitlab.com/ammongit/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "0.1.$(git describe --always)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m755 'days_until.py' "$pkgdir/usr/bin/daysuntil"
+ install -D -m644 'sample_event_list.txt' "$pkgdir/usr/share/$_pkgname/sample_event_list.txt"
+ install -D -m644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+