summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaansu2015-08-13 03:26:07 -0700
committerRaansu2015-08-13 03:26:07 -0700
commit1ad94935f53672a252d793d4279fd86d5996aa0a (patch)
tree857863f55c8d223729f115a8700ff57b035fb173
parenta9885f4fbf0a0fe7501fa6dd404263a3750bab99 (diff)
downloadaur-1ad94935f53672a252d793d4279fd86d5996aa0a.tar.gz
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79e3555d40b4..3325051585be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,10 +27,12 @@ package() {
cd "build_unix"
make prefix="$pkgdir/usr" includedir="$pkgdir/usr/include/db4.8" install
+# Remove documents to save space, these can be found online if needed.
+ rm -rf "$pkgdir/usr/docs"
+
# Remove conflicting symlinks created by make, should never overwrite
# main libdb symlinks to current version. Programs that need or use
# db4.8 should be able to find it.
- rm -rf "$pkgdir/usr/docs"
rm -f "$pkgdir/usr/lib/libdb.so"
rm -f "$pkgdir/usr/lib/libdb_cxx.so"
rm -f "$pkgdir/usr/lib/libdb-4.so"
@@ -44,7 +46,7 @@ package() {
mv $i db4.8_${i/db_/}
done
-# Install license
+# Install license.
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
install -m644 "$srcdir/db-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}