summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-05-10 13:56:09 -0400
committerJames An2016-05-10 13:56:09 -0400
commit40cb39aed9b0960badd1ba387d9664cacd2e1b96 (patch)
treee752df37d571d0fef471861da71b807d2042aec8
downloadaur-40cb39aed9b0960badd1ba387d9664cacd2e1b96.tar.gz
Initial commit with working spec.
-rw-r--r--.SRCINFO21
-rwxr-xr-x.gitignore27
-rw-r--r--PKGBUILD34
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0883c3ca0c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = db6.2
+ pkgdesc = The Berkeley DB embedded database system 6.2
+ pkgver = 6.2.23
+ pkgrel = 1
+ url = http://www.oracle.com/technology/software/products/berkeley-db/index.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = sh
+ provides = db=6.2.23
+ conflicts = db
+ conflicts = db4.5
+ conflicts = db4.6
+ conflicts = db4.8
+ conflicts = db5.2
+ source = http://download.oracle.com/berkeley-db/db-6.2.23.tar.gz
+ sha1sums = 646c57b99799dc300207976e2270cdaca1a2f198
+
+pkgname = db6.2
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a56ec5eede1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: James An <james@jamesan.ca>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=db6.2
+_pkgname=${pkgname%[0-9]*\.[0-9]*}
+pkgver=6.2.23
+_pkgver=${pkgver%\.[0-9]*}
+pkgrel=1
+pkgdesc="The Berkeley DB embedded database system $_pkgver"
+arch=('i686' 'x86_64')
+url="http://www.oracle.com/technology/software/products/berkeley-$_pkgname/index.html"
+license=('custom')
+depends=('gcc-libs' 'sh')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname"{,4.{5,6,8},5.2})
+source=("http://download.oracle.com/berkeley-$_pkgname/$_pkgname-${pkgver}.tar.gz")
+sha1sums=('646c57b99799dc300207976e2270cdaca1a2f198')
+
+build() {
+ cd "$_pkgname-$pkgver/build_unix"
+ ../dist/configure --prefix=/usr --enable-compat185 \
+ --enable-shared --enable-cxx --enable-dbm \
+ --enable-stl
+ make LIBSO_LIBS=-lpthread
+}
+
+package() {
+ cd "$_pkgname-$pkgver/build_unix"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir/usr/docs"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}