summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Sivak2018-03-12 10:08:19 -0400
committerJohn Sivak2018-03-12 10:08:19 -0400
commit386299c8bb59498062ed6ecd483c6a838f019655 (patch)
tree86039b871452f265cea842034128e8f360bda30d
parentbfa1f0c7b86630153f6e478fc62706e41ba8fa3a (diff)
downloadaur-386299c8bb59498062ed6ecd483c6a838f019655.tar.gz
Add instructions and a copy of mksrcinfo script.
-rwxr-xr-xmksrcinfo6
-rw-r--r--packaging_steps.rst8
2 files changed, 14 insertions, 0 deletions
diff --git a/mksrcinfo b/mksrcinfo
new file mode 100755
index 000000000000..41ce36ccaacc
--- /dev/null
+++ b/mksrcinfo
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ -f .SRCINFO ]]; then
+ makepkg --printsrcinfo > .SRCINFO
+else
+ echo "No .SRCINFO file found."
+fi
diff --git a/packaging_steps.rst b/packaging_steps.rst
new file mode 100644
index 000000000000..1452450985d9
--- /dev/null
+++ b/packaging_steps.rst
@@ -0,0 +1,8 @@
+When new version is available do the following:
+
+#. Update the PKGBUILD file
+#. run ``updpkgsums``
+#. run ``mksrcinfo``
+#. run ``makepkg``
+#. Test the package by installing locally.
+#. If everything works, then commit and push