summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathas2015-06-09 23:00:42 -0300
committerJonathas2015-06-09 23:00:42 -0300
commita6b31a51fb7e06961105d758d38a39031ed40d49 (patch)
tree224e3b1e43c4851bf0880ddc74317530a098ed77
downloadaur-a6b31a51fb7e06961105d758d38a39031ed40d49.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2061c20187e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dbf
+ pkgdesc = Command line tool to show and convert the content of dBASE III, IV, and 5.0 files
+ pkgver = 0.9.0
+ pkgrel = 3
+ url = http://sourceforge.net/projects/dbf
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = libdbf
+ source = http://ftp.mirrorservice.org/sites/download.sourceforge.net/pub/sourceforge/d/db/dbf.berlios/dbf-core-0.9.0.src.zip
+ md5sums = fb5c016d9e45a95c1956d959792a5063
+
+pkgname = dbf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62b77aaf3aaa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jon Ribeiro <contact@jonathas.com>
+pkgname=dbf
+pkgver=0.9.0
+pkgrel=3
+pkgdesc="Command line tool to show and convert the content of dBASE III, IV, and 5.0 files"
+url="http://sourceforge.net/projects/dbf"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libdbf')
+makedepends=('unzip')
+source=(http://ftp.mirrorservice.org/sites/download.sourceforge.net/pub/sourceforge/d/db/dbf.berlios/dbf-core-0.9.0.src.zip)
+md5sums=('fb5c016d9e45a95c1956d959792a5063')
+
+build() {
+ cd "${srcdir}/$pkgname-core"
+ chmod +x autogen.sh
+ rm configure install-sh depcomp missing
+ ./autogen.sh && ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/$pkgname-core"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}" -name '*.la' -exec rm {} \;
+}