summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharkdp2019-12-30 10:30:14 +0100
committersharkdp2019-12-30 10:30:14 +0100
commit57f1c2d2dcf7ff98729b7ebe036c29f1bd2cd1b4 (patch)
tree865430cb0359f344d5696b8dfc2949e4ab025adf
downloadaur-57f1c2d2dcf7ff98729b7ebe036c29f1bd2cd1b4.tar.gz
Initial PKGBUILD for v0.2.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78c1624f992d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dbg-macro
+ pkgdesc = A C++ macro for printf-style debugging fans.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/sharkdp/dbg-macro
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ source = git+https://github.com/sharkdp/dbg-macro/#tag=v0.2.1
+ source = git+https://github.com/catchorg/Catch2#tag=v2.11.1
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = dbg-macro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cba81fc6f82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: David Peter <mail@david-peter.de>
+pkgname=dbg-macro
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A C++ macro for printf-style debugging fans."
+arch=(any)
+url="https://github.com/sharkdp/dbg-macro"
+license=('MIT')
+depends=()
+optdepends=()
+makedepends=('git' 'cmake')
+source=("git+https://github.com/sharkdp/dbg-macro/#tag=v${pkgver}"
+ "git+https://github.com/catchorg/Catch2#tag=v2.11.1")
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "${pkgname}"
+
+ git submodule init
+ git config submodule."tests/Catch2".url "$srcdir"/Catch2
+ git submodule update
+}
+
+build() {
+ cd "${pkgname}"
+
+ git submodule init
+
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DDBG_MACRO_ENABLE_TESTS=1
+ make
+}
+
+check() {
+ cd "${pkgname}/build"
+ make test
+}
+
+package() {
+ cd "${pkgname}/build"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: