summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraulonsal2021-05-09 19:05:29 +0530
committeraulonsal2021-05-09 19:05:29 +0530
commit10c5e94e263d9e04a984d21eb7032ca4faa42777 (patch)
treed7f6a3c9d4a4c3431ae5bd2f8fb9130f961e2cd0
downloadaur-10c5e94e263d9e04a984d21eb7032ca4faa42777.tar.gz
Initial upload: dbgate-bin 4.1.12-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a78a59e35e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dbgate-bin
+ pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server and MongoDB.
+ pkgver = 4.1.12
+ pkgrel = 1
+ url = https://github.com/dbgate/dbgate
+ arch = x86_64
+ license = MIT
+ depends = nss
+ depends = gtk3
+ provides = dbgate
+ conflicts = dbgate
+ noextract = dbgate-bin-4.1.12.deb
+ source = dbgate-bin-4.1.12.deb::https://github.com/dbgate/dbgate/releases/download/v4.1.12/dbgate-linux-4.1.12.deb
+ source = dbgate-bin-4.1.12-LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/master/LICENSE
+ b2sums = e17a6b588291bc5be4855c775bc7129a3caafd7ec95eb5b8bba1efb178edb5e6f7c4eacdeaf23336600cfd1452dd6b7c47aa93a0ad945b146739834d6944ba0c
+ b2sums = 9cc4e2813f0978862b0960aa0c8d5b0bc75ae299f10b793ae152202f2e6f43127381c9153c6f51ca1bc83ab633d198dac5d817105a8e7b43e1aad401e0b6eb2f
+
+pkgname = dbgate-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e3a638d916b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: aulonsal <aulonsal at gmail dot com>
+pkgname=dbgate-bin
+pkgver=4.1.12
+pkgrel=1
+pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server and MongoDB."
+arch=(x86_64)
+url="https://github.com/${pkgname%-bin}/${pkgname%-bin}"
+license=('MIT')
+depends=(
+ nss
+ gtk3
+)
+provides=(${pkgname%-bin})
+conflicts=(${pkgname%-bin})
+source=(
+ "$pkgname-$pkgver.deb::$url/releases/download/v$pkgver/dbgate-linux-$pkgver.deb"
+ "$pkgname-$pkgver-LICENSE::${url/github/raw.githubusercontent}/master/LICENSE"
+)
+noextract=("$pkgname-$pkgver.deb")
+
+b2sums=(
+ 'e17a6b588291bc5be4855c775bc7129a3caafd7ec95eb5b8bba1efb178edb5e6f7c4eacdeaf23336600cfd1452dd6b7c47aa93a0ad945b146739834d6944ba0c'
+ '9cc4e2813f0978862b0960aa0c8d5b0bc75ae299f10b793ae152202f2e6f43127381c9153c6f51ca1bc83ab633d198dac5d817105a8e7b43e1aad401e0b6eb2f'
+)
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p "$pkgname-$pkgver/data"
+ cd "$pkgname-$pkgver"
+ bsdtar -xf ../"$pkgname-$pkgver.deb"
+}
+
+package() {
+ install -Dm644 "$pkgname-$pkgver-LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ bsdtar -xf data.tar.xz --directory="$pkgdir"
+}