summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-07 12:18:43 +0800
committerzxp198210052024-02-07 12:18:43 +0800
commit987d3d9fe6d9eda8dcf506bcf8f22f3bc70209ef (patch)
treeac7a0aa91233d94c29a7c95095fe704237cbeff9
parent4155ceb255c765caaa6f96c4fc03286ac5cb4a7d (diff)
downloadaur-987d3d9fe6d9eda8dcf506bcf8f22f3bc70209ef.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--dbgate.sh9
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 381cc77a7240..88e1d0d39694 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dbgate-bin
pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application
pkgver = 5.2.7
- pkgrel = 3
+ pkgrel = 4
url = https://dbgate.org/
arch = aarch64
arch = armv7h
@@ -17,7 +17,7 @@ pkgbase = dbgate-bin
source = LICENSE-5.2.7::https://raw.githubusercontent.com/dbgate/dbgate/v5.2.7/LICENSE
source = dbgate.sh
sha256sums = 4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
source_aarch64 = dbgate-5.2.7-aarch64.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_arm64.AppImage
sha256sums_aarch64 = c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22
source_armv7h = dbgate-5.2.7-armv7h.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.7/dbgate-5.2.7-linux_armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 281a23fd5feb..5c96ffd8f592 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dbgate-bin
pkgver=5.2.7
_electronversion=25
-pkgrel=3
+pkgrel=4
pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application"
arch=(
'aarch64'
@@ -32,14 +32,14 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('c0f659c4feb350067b29c202656669b3dabb19a9626f6a2df3a51a7116a56a22')
sha256sums_armv7h=('cc0c7b59475a254bda665b835dcf7f145813f2daa5687dc41e2116b13195fd04')
sha256sums_x86_64=('75801a25bcd13b1f1073f2c8c048f49c7ebe58eb1162f5105b486a0ce99a8696')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
diff --git a/dbgate.sh b/dbgate.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/dbgate.sh
+++ b/dbgate.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file