summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2016-03-04 18:03:14 +0300
committersurefire2016-03-04 18:05:12 +0300
commit0f2aeb2a83fbdb3c6710c293cf170eedad99dc97 (patch)
tree4bdfa6e3611c2ab6df27d299427fdf9f52ce7e47
downloadaur-0f2aeb2a83fbdb3c6710c293cf170eedad99dc97.tar.gz
Initial
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--install22
-rw-r--r--service11
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..546e12263efc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Mar 4 15:02:28 UTC 2016
+pkgbase = dbninja
+ pkgdesc = Advanced web-based application for MySQL database administration and development
+ pkgver = 3.2.6
+ pkgrel = 1
+ url = http://www.dbninja.com/
+ install = install
+ arch = any
+ license = custom: EULA
+ depends = php
+ source = http://www.dbninja.com/download/dbninja.tar.gz
+ source = service
+ md5sums = 81df97958467776051507f82a680efde
+ md5sums = SKIP
+
+pkgname = dbninja
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5512a0abf371
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: surefire <surefire@cryptomile.net>
+
+
+pkgname='dbninja'
+pkgver=3.2.6
+pkgrel=1
+pkgdesc="Advanced web-based application for MySQL database administration and development"
+arch=("any")
+url="http://www.dbninja.com/"
+license=("custom: EULA")
+depends=("php")
+source=('http://www.dbninja.com/download/dbninja.tar.gz'
+ "service")
+md5sums=("81df97958467776051507f82a680efde"
+ "SKIP")
+
+install="install"
+
+package() {
+ _instdir="/usr/share/webapps/dbninja"
+ _vardir="/var/lib/dbninja"
+
+ install -Dm0644 "service" "${pkgdir}/usr/lib/systemd/system/dbninja-localhost.service"
+
+ cd "${srcdir}/${pkgname}"
+
+ install -dm0755 "${pkgdir}/${_instdir}"
+ install -dm0755 "${pkgdir}/${_vardir}"
+ install -dm0755 "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ chown nobody "_users"
+
+ mv "_users" "${pkgdir}/${_vardir}"
+
+ cp -r . "${pkgdir}/${_instdir}"
+
+ ln -s "${_vardir}/_users" "${pkgdir}/${_instdir}/_users"
+ ln -s "${_instdir}/license.html" "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..82aa726d0a6b
--- /dev/null
+++ b/install
@@ -0,0 +1,22 @@
+post_install() {
+
+cat <<EOF
+=============================================
+
+For localhost use please start service:
+ systemctl daemon-reload
+ systemctl start dbninja-localhost.service
+
+Open DbNinja in browser http://127.0.30.36:8080
+
+After accepting the license agreement, find the code file:
+ ls /var/lib/dbninja/_users
+
+Autostart service:
+ systemctl enable dbninja-localhost.service
+
+==============================================
+EOF
+
+}
+
diff --git a/service b/service
new file mode 100644
index 000000000000..2009fb187711
--- /dev/null
+++ b/service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Advanced web-based application for MySQL database administration and development
+After=network.target
+
+[Service]
+User=nobody
+Group=nobody
+ExecStart=/usr/bin/php -n -d extension=mysqli.so -S 127.0.30.36:8080 -t /usr/share/webapps/dbninja
+
+[Install]
+WantedBy=multi-user.target