summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Cioli2018-03-20 13:40:33 -0500
committerNicholas Cioli2018-03-20 13:40:33 -0500
commit04c8277a891659bf74957944b9bef436747a0e15 (patch)
tree8d5b86137a2d510101442c649dbe9cd675f27d57
downloadaur-dbow2-free.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e46fd543d64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dbow2-free
+ pkgdesc = Enhanced hierarchical bag-of-word library for C++. No support for non-free features
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/dorian3d/DBoW2
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = gcc
+ depends = dlib-free
+ conflicts = dbow2-nonfree
+ source = https://github.com/dorian3d/DBoW2/archive/v1.1-free.tar.gz
+ md5sums = 2764979e5be6bc7a7f041892d6527af4
+
+pkgname = dbow2-free
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46e16b8d2a6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Nicholas Cioli <nicholascioli+arch@gmail.com>
+pkgname=dbow2-free
+pkgver=1.1
+pkgrel=1
+pkgdesc="Enhanced hierarchical bag-of-word library for C++. No support for non-free features"
+arch=('x86_64')
+url="https://github.com/dorian3d/DBoW2"
+license=('custom')
+depends=(dlib-free)
+makedepends=(cmake gcc)
+provides=()
+conflicts=(dbow2-nonfree)
+source=(
+ "https://github.com/dorian3d/DBoW2/archive/v$pkgver-free.tar.gz"
+)
+md5sums=(
+ "2764979e5be6bc7a7f041892d6527af4"
+)
+
+build() {
+ cd "DBoW2-$pkgver-free"
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+ cd build
+ cmake .. \
+ -DBUILD_Demo=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "DBoW2-$pkgver-free/build"
+ make DESTDIR="$pkgdir/" install
+
+ # Install the license
+ install -Dm644 ../LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}