summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-10-26 02:02:58 -0400
committeracxz2019-10-26 02:02:58 -0400
commit6c6efa0cd5c8bdb7c9166c7a652ec34d56903c1f (patch)
tree0c229af10b9bd03754312d7cda996201f1a1a09a
downloadaur-6c6efa0cd5c8bdb7c9166c7a652ec34d56903c1f.tar.gz
create dbow2-git package
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE.txt46
-rw-r--r--PKGBUILD37
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a3874943328
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dbow2-git
+ pkgdesc = Enhanced hierarchical bag-of-word library for C++.
+ pkgver = r28.4d08e9f
+ pkgrel = 1
+ url = https://github.com/dorian3d/DBoW2
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = gcc
+ depends = gcc
+ provides = dbow2
+ source = git+https://github.com/dorian3d/DBoW2.git
+ source = LICENSE.txt
+ sha256sums = SKIP
+ sha256sums = c02e19ed871eb9dd11b01db600d3f3601c5a03c4121f6baeb2ebe215ecbeaf23
+
+pkgname = dbow2-git
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..376332c15973
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,46 @@
+DBoW2: bag-of-words library for C++ with generic descriptors
+
+Copyright (c) 2015 Dorian Galvez-Lopez. http://doriangalvez.com
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. The original author of the work must be notified of any
+ redistribution of source code or in binary form.
+4. Neither the name of copyright holders nor the names of its
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL COPYRIGHT HOLDERS OR CONTRIBUTORS
+BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
+
+If you use it in an academic work, please cite:
+
+ @ARTICLE{GalvezTRO12,
+ author={G\'alvez-L\'opez, Dorian and Tard\'os, J. D.},
+ journal={IEEE Transactions on Robotics},
+ title={Bags of Binary Words for Fast Place Recognition in Image Sequences},
+ year={2012},
+ month={October},
+ volume={28},
+ number={5},
+ pages={1188--1197},
+ doi={10.1109/TRO.2012.2197158},
+ ISSN={1552-3098}
+ }
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cec188e6b99a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=dbow2-git
+pkgver=r28.4d08e9f
+pkgrel=1
+pkgdesc="Enhanced hierarchical bag-of-word library for C++."
+arch=('x86_64')
+url="https://github.com/dorian3d/DBoW2"
+license=('custom')
+depends=('gcc')
+makedepends=('cmake' 'gcc')
+provides=('dbow2')
+_name=DBoW2
+source=("git+https://github.com/dorian3d/DBoW2.git"
+ LICENSE.txt)
+sha256sums=('SKIP'
+ 'c02e19ed871eb9dd11b01db600d3f3601c5a03c4121f6baeb2ebe215ecbeaf23')
+
+pkgver() {
+ cd "$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_name}"
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DBUILD_Demo=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${_name}/build"
+ make DESTDIR="$pkgdir/" install
+}