summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniël van de Giessen2024-03-24 15:24:10 +0100
committerDaniël van de Giessen2024-03-24 15:24:10 +0100
commitafd8c1b7f1c158b49f0347c5c6d8f0441c32f012 (patch)
tree31b72760a846d2193a4294d66dbd658b804c46d6
downloadaur-afd8c1b7f1c158b49f0347c5c6d8f0441c32f012.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD36
-rw-r--r--nl.dvdgiessen.dbusapplauncher.service4
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4ed46d4151f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dbus-app-launcher
+ pkgdesc = Simple app launcher for D-Bus
+ pkgver = 0.1.0.0
+ pkgrel = 1
+ url = https://github.com/DvdGiessen/dbus-app-launcher
+ arch = x86_64
+ license = MIT
+ makedepends = ghc
+ makedepends = uusi
+ depends = ghc-libs
+ depends = haskell-dbus
+ depends = haskell-extra
+ source = https://hackage.haskell.org/packages/archive/dbus-app-launcher/0.1.0.0/dbus-app-launcher-0.1.0.0.tar.gz
+ source = nl.dvdgiessen.dbusapplauncher.service
+ sha256sums = bb09fc801920df9d217a0993064c7848a9811d8b24bd26119aa963f327305490
+ sha256sums = bdf13de2547f626ff797070f493999577b9f499d72e904b5d7801e92d11b0387
+
+pkgname = dbus-app-launcher
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aaf671ff3827
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!nl.dvdgiessen.dbusapplauncher.service
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00a91fa906f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniël van de Giessen <aur@dvdgiessen.nl>
+pkgname=dbus-app-launcher
+pkgver=0.1.0.0
+pkgrel=1
+pkgdesc="Simple app launcher for D-Bus"
+arch=('x86_64')
+url="https://github.com/DvdGiessen/dbus-app-launcher"
+license=("MIT")
+depends=('ghc-libs' 'haskell-dbus' 'haskell-extra')
+makedepends=('ghc' 'uusi')
+source=("https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz" 'nl.dvdgiessen.dbusapplauncher.service')
+sha256sums=('bb09fc801920df9d217a0993064c7848a9811d8b24bd26119aa963f327305490' 'bdf13de2547f626ff797070f493999577b9f499d72e904b5d7801e92d11b0387')
+
+prepare() {
+ uusi $pkgname-$pkgver/$pkgname.cabal
+}
+
+build() {
+ cd $pkgname-$pkgver
+ runhaskell Setup configure \
+ -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+ runhaskell Setup build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -rf "$pkgdir"/usr/share/doc/
+ cd ..
+ install -D -m644 nl.dvdgiessen.dbusapplauncher.service -t "$pkgdir/usr/share/dbus-1/services/"
+}
diff --git a/nl.dvdgiessen.dbusapplauncher.service b/nl.dvdgiessen.dbusapplauncher.service
new file mode 100644
index 000000000000..34d657766932
--- /dev/null
+++ b/nl.dvdgiessen.dbusapplauncher.service
@@ -0,0 +1,4 @@
+[D-BUS Service]
+Name=nl.dvdgiessen.dbusapplauncher
+Exec=/usr/bin/dbus-app-launcher
+