summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rheinsberg2022-05-10 12:30:38 +0200
committerDavid Rheinsberg2022-05-10 12:30:38 +0200
commitd5d5745ce0b529f571482d0a085bf7e0ba635c32 (patch)
tree9a112366ea8f40febaabd657c2776ed65d095f0b
parent620db2b2f418763ab4ae056d56f1c424d00e5ae4 (diff)
downloadaur-d5d5745ce0b529f571482d0a085bf7e0ba635c32.tar.gz
dbus-broker-git: use new meson-wrap
Update the build instructions to the new dbus-broker-30 way of including subprojects. Since we want to use offline-builds, pull in the submodules from their respective branches. Signed-off-by: David Rheinsberg <david.rheinsberg@gmail.com>
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d86abd1cba6..40143c704239 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,26 @@
_pkgorg=bus1
_pkgname=dbus-broker
pkgdesc='Linux D-Bus Message Broker'
-pkgver=r1405.72da24b
+pkgver=r1484.cf3b49c
pkgrel=1
pkgname=$_pkgname-git
arch=('x86_64')
url="https://github.com/$_pkgorg/$_pkgname"
license=('Apache')
-depends=('audit' 'expat' 'systemd-libs')
-makedepends=('git' 'meson' 'systemd' 'python-docutils')
+depends=('audit>=3.0' 'expat>=2.2' 'libcap-ng>=0.6' 'linux>=4.17' 'systemd-libs>=230')
+makedepends=('git' 'meson>=0.60.0' 'systemd' 'python-docutils')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+https://github.com/$_pkgorg/$_pkgname"
- git+https://github.com/c-util/c-{dvar,ini,list,rbtree,shquote,stdaux,utf8})
+ "c-dvar-1::git+https://github.com/c-util/c-dvar#branch=v1"
+ "c-ini-1::git+https://github.com/c-util/c-ini#branch=v1"
+ "c-list-3::git+https://github.com/c-util/c-list#branch=v3"
+ "c-rbtree-3::git+https://github.com/c-util/c-rbtree#branch=v3"
+ "c-shquote-1::git+https://github.com/c-util/c-shquote#branch=v1"
+ "c-stdaux-1::git+https://github.com/c-util/c-stdaux#branch=v1"
+ "c-utf8-1::git+https://github.com/c-util/c-utf8#branch=v1")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -34,14 +40,10 @@ pkgver() {
prepare() {
cd $pkgname
- git submodule init
-
- local sm
- for sm in c-{dvar,ini,list,rbtree,shquote,stdaux,utf8}; do
- git submodule set-url subprojects/$sm "$srcdir/$sm"
+ local sp
+ for sp in {dvar-1,ini-1,list-3,rbtree-3,shquote-1,stdaux-1,utf8-1}; do
+ ln -fs "$srcdir/c-$sp" "subprojects/libc$sp"
done
-
- git submodule update
}
build() {