summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rheinsberg2020-02-05 13:08:05 +0100
committerDavid Rheinsberg2020-02-05 13:08:05 +0100
commitf7d9695b56ae12e13e6bf39c76287269f6d29406 (patch)
tree0c16f9ce9c92f239f3c1bcb409969a78510721e9
parentc7a92901c1ee5be053eaecb6b69f89435e36c421 (diff)
downloadaur-f7d9695b56ae12e13e6bf39c76287269f6d29406.tar.gz
dbus-broker-git: sync with non-git package
Synchronize all the details with the non-git package so we stay up-to-date and do not deviate from it. Signed-off-by: David Rheinsberg <david.rheinsberg@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37a4a356cde5..5a17225f3209 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Apr 11 11:49:47 UTC 2019
+# Wed Feb 5 12:07:55 UTC 2020
pkgbase = dbus-broker-git
pkgdesc = Linux D-Bus Message Broker
- pkgver = r1358.ced4d83
+ pkgver = r1379.191f135
pkgrel = 1
url = https://github.com/bus1/dbus-broker
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index eecd4d69fa32..e219d6092c19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgorg=bus1
_pkgname=dbus-broker
pkgdesc='Linux D-Bus Message Broker'
-pkgver=r1358.ced4d83
+pkgver=r1379.191f135
pkgrel=1
pkgname=$_pkgname-git
@@ -32,8 +32,6 @@ pkgver() {
}
prepare() {
- rm -Rf build
- mkdir build
cd $pkgname
git submodule init
@@ -47,24 +45,19 @@ prepare() {
}
build() {
- cd build
- CFLAGS="$CFLAGS -Wno-unused-parameter"
- CFLAGS="$CFLAGS -Wno-maybe-uninitialized"
- arch-meson "." "../$pkgname" \
- -Ddocs=true \
- -Daudit=true \
- -Dsystem-console-users=gdm
- ninja
+ arch-meson $pkgname build \
+ -D audit=true \
+ -D docs=true \
+ -D system-console-users=gdm,sddm,lightdm,lxdm
+ ninja -C build
}
check() {
- cd build
- meson test
+ meson test -C build --print-errorlogs
}
package() {
- cd build
- DESTDIR="$pkgdir" meson install
+ DESTDIR="$pkgdir" meson install -C build
}
# vim:set sw=2 et: