summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIwan Timmer2018-03-15 22:33:15 +0100
committerIwan Timmer2018-03-15 22:33:15 +0100
commit92451d8c750c5ae1703e542bbd1277ef4ec297bd (patch)
tree62993717ba06e7877b9c014626cb40de4f40b166
parente734596a524cb3f5e99759b47792d77b00d6c6e7 (diff)
downloadaur-92451d8c750c5ae1703e542bbd1277ef4ec297bd.tar.gz
Provide patch for Boost 1.66
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--boost-asio-1-66.patch16
3 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f872c639287..58690da952f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dbus-cpp
pkgdesc = A header-only dbus-binding leveraging C++-11
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://code.launchpad.net/dbus-cpp
arch = x86_64
license = LGPL3
@@ -13,7 +13,9 @@ pkgbase = dbus-cpp
depends = dbus
depends = libxml2
source = https://launchpad.net/ubuntu/+archive/primary/+files/dbus-cpp_5.0.0+18.04.20171031.orig.tar.gz
+ source = boost-asio-1-66.patch
md5sums = 61e9568f3c799214c5bc8b5e3a498496
+ md5sums = 127dde628ffb8296516090228975cfc2
pkgname = dbus-cpp
diff --git a/PKGBUILD b/PKGBUILD
index b6bc9b51d07e..31c353c8194f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,20 @@ url="https://code.launchpad.net/dbus-cpp"
license=('LGPL3')
depends=('process-cpp' 'dbus' 'libxml2')
makedepends=('cmake' 'gmock' 'properties-cpp' 'boost')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/dbus-cpp_${_pkgver}.orig.tar.gz")
-md5sums=('61e9568f3c799214c5bc8b5e3a498496')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/dbus-cpp_${_pkgver}.orig.tar.gz"
+ "boost-asio-1-66.patch")
+md5sums=('61e9568f3c799214c5bc8b5e3a498496'
+ '127dde628ffb8296516090228975cfc2')
prepare() {
cd "$srcdir"
# Don't build tests
truncate -s 0 tests/CMakeLists.txt
+
+ # Fix boost asio 1.66 API changes
+ # https://github.com/anbox/anbox/issues/637#issuecomment-373361974
+ patch -Np1 -i boost-asio-1-66.patch
}
build() {
diff --git a/boost-asio-1-66.patch b/boost-asio-1-66.patch
new file mode 100644
index 000000000000..181fb1da6dfa
--- /dev/null
+++ b/boost-asio-1-66.patch
@@ -0,0 +1,16 @@
+diff --git a/include/core/dbus/asio/executor.h b/include/core/dbus/asio/executor.h
+index d1f043e..7cbece2 100644
+--- a/include/core/dbus/asio/executor.h
++++ b/include/core/dbus/asio/executor.h
+@@ -26,7 +26,11 @@ namespace boost
+ {
+ namespace asio
+ {
++#if BOOST_VERSION >= 106600
++class io_context;
++#else
+ class io_service;
++#endif
+ }
+ }
+