summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Semkin2019-11-20 22:54:02 +0300
committerIvan Semkin2019-11-20 22:54:02 +0300
commited8024bb0f6df3cd32e3f7ea382db49826c2fe9c (patch)
treeaac710aeb4336292fbb27459d096bd52868c6f2b
parent43971177cd7ae2de9beca936b0b20dbf9f382f72 (diff)
downloadaur-ed8024bb0f6df3cd32e3f7ea382db49826c2fe9c.tar.gz
Ignore deprecation warnings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88a18daf375a..12b84ec096d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dbus-cpp
pkgdesc = A header-only dbus-binding leveraging C++-11
pkgver = 5.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://code.launchpad.net/dbus-cpp
arch = x86_64
license = LGPL3
@@ -9,6 +9,8 @@ pkgbase = dbus-cpp
makedepends = gmock
makedepends = properties-cpp
makedepends = boost
+ makedepends = lcov
+ makedepends = gcovr
depends = process-cpp
depends = dbus
depends = libxml2
diff --git a/PKGBUILD b/PKGBUILD
index c2a83e64b799..3751327d52a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ pkgname=dbus-cpp
pkgdesc='A header-only dbus-binding leveraging C++-11'
pkgver=5.0.0
_pkgver=5.0.0+18.04.20171031
-pkgrel=4
+pkgrel=5
url='https://code.launchpad.net/dbus-cpp'
arch=(x86_64)
license=(LGPL3)
depends=(process-cpp dbus libxml2)
-makedepends=(cmake gmock properties-cpp boost)
+makedepends=(cmake gmock properties-cpp boost lcov gcovr)
source=("https://launchpad.net/ubuntu/+archive/primary/+files/dbus-cpp_${_pkgver}.orig.tar.gz"
'boost-asio-1-66.patch')
sha256sums=('e0d426027acd65f7e568c53e974ae3e666f0af2e75b2d2afed3dae721a6e9e38'
@@ -31,7 +31,7 @@ build() {
mkdir -p "${srcdir}/build"
cd "${srcdir}/build"
- cmake .. -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DDBUS_CPP_VERSION_MAJOR=5 -DDBUS_CPP_VERSION_MINOR=0 -DDBUS_CPP_VERSION_PATCH=0
+ CXXFLAGS=-Wno-error=deprecated-copy cmake .. -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DDBUS_CPP_VERSION_MAJOR=5 -DDBUS_CPP_VERSION_MINOR=0 -DDBUS_CPP_VERSION_PATCH=0
make
}