summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-23 15:55:08 +0800
committerChocobo12017-08-23 16:47:41 +0800
commit0d30f5ddfc62132ecc7c52363af7a99cf7de20c3 (patch)
tree5a90d75a3bfbdcfe5e977b094f5ba4bcaec4809f
downloadaur-0d30f5ddfc62132ecc7c52363af7a99cf7de20c3.tar.gz
newpkg: dbus-git 1.11.16.r31.gd82378fd-1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD60
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93d4383b8b27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = dbus-git
+ pkgdesc = Message bus system
+ pkgver = 1.11.16.r31.gd82378fd
+ pkgrel = 1
+ url = https://wiki.freedesktop.org/www/Software/dbus/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = git
+ makedepends = autoconf-archive
+ makedepends = systemd
+ depends = glibc
+ depends = expat
+ depends = gettext
+ depends = libsystemd
+ provides = libdbus
+ provides = dbus
+ conflicts = libdbus
+ conflicts = dbus
+ options = staticlibs
+ source = git+https://anongit.freedesktop.org/git/dbus/dbus.git
+ source = dbus.sysusers::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dbus.sysusers?h=packages/dbus
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = dbus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b02c27e601d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=dbus-git
+pkgver=1.11.16.r31.gd82378fd
+pkgrel=1
+pkgdesc="Message bus system"
+arch=('i686' 'x86_64')
+url="https://wiki.freedesktop.org/www/Software/dbus/"
+license=('GPL' 'custom')
+depends=('glibc' 'expat' 'gettext' 'libsystemd')
+makedepends=('git' 'autoconf-archive' 'systemd')
+provides=('libdbus' 'dbus')
+conflicts=('libdbus' 'dbus')
+options=('staticlibs')
+source=("git+https://anongit.freedesktop.org/git/dbus/dbus.git"
+ "dbus.sysusers::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dbus.sysusers?h=packages/dbus")
+sha256sums=('SKIP'
+ 'SKIP')
+
+
+pkgver() {
+ cd "dbus"
+
+ git describe --long --tags | sed 's/^dbus-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "dbus"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix="/usr" \
+ --sysconfdir="/etc" \
+ --localstatedir="/var" \
+ --libexecdir="/usr/lib/dbus-1.0" \
+ --with-system-pid-file="/run/dbus/pid" \
+ --with-system-socket="/run/dbus/system_bus_socket" \
+ --with-console-auth-dir="/run/console" \
+ --with-systemdsystemunitdir="/usr/lib/systemd/system" \
+ --with-dbus-user=dbus --enable-systemd --enable-user-session --enable-epoll
+ make
+}
+
+check() {
+ cd "dbus"
+
+ make check
+}
+
+package() {
+ cd "dbus"
+
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir/usr/share/doc"
+ rm -r "$pkgdir/var/run"
+
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/dbus/COPYING"
+
+ install -Dm644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+}