summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-23 01:10:19 +0800
committerChocobo12019-05-23 01:14:12 +0800
commit59d010ed0a5f30b3b0626a28845fe9838677c3e7 (patch)
treeed327ac8931448a255f812c5879255a2e17dca45
parent0d30f5ddfc62132ecc7c52363af7a99cf7de20c3 (diff)
downloadaur-59d010ed0a5f30b3b0626a28845fe9838677c3e7.tar.gz
upgpkg: dbus-git 1.13.10.r2.gedece027-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93d4383b8b27..0aabe6b0b8ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = dbus-git
pkgdesc = Message bus system
- pkgver = 1.11.16.r31.gd82378fd
+ pkgver = 1.13.10.r2.gedece027
pkgrel = 1
- url = https://wiki.freedesktop.org/www/Software/dbus/
+ url = https://www.freedesktop.org/wiki/Software/dbus/
arch = i686
arch = x86_64
license = GPL
@@ -11,17 +11,15 @@ pkgbase = dbus-git
makedepends = autoconf-archive
makedepends = systemd
depends = glibc
+ depends = audit
depends = expat
- depends = gettext
- depends = libsystemd
+ depends = systemd-libs
provides = libdbus
provides = dbus
conflicts = libdbus
conflicts = dbus
options = staticlibs
- source = git+https://anongit.freedesktop.org/git/dbus/dbus.git
- source = dbus.sysusers::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dbus.sysusers?h=packages/dbus
- sha256sums = SKIP
+ source = git+https://gitlab.freedesktop.org/dbus/dbus.git
sha256sums = SKIP
pkgname = dbus-git
diff --git a/PKGBUILD b/PKGBUILD
index b02c27e601d4..7e9b916d7f8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=dbus-git
-pkgver=1.11.16.r31.gd82378fd
+pkgver=1.13.10.r2.gedece027
pkgrel=1
pkgdesc="Message bus system"
arch=('i686' 'x86_64')
-url="https://wiki.freedesktop.org/www/Software/dbus/"
+url="https://www.freedesktop.org/wiki/Software/dbus/"
license=('GPL' 'custom')
-depends=('glibc' 'expat' 'gettext' 'libsystemd')
+depends=('glibc' 'audit' 'expat' 'systemd-libs')
makedepends=('git' 'autoconf-archive' 'systemd')
provides=('libdbus' 'dbus')
conflicts=('libdbus' 'dbus')
options=('staticlibs')
-source=("git+https://anongit.freedesktop.org/git/dbus/dbus.git"
- "dbus.sysusers::https://git.archlinux.org/svntogit/packages.git/plain/trunk/dbus.sysusers?h=packages/dbus")
-sha256sums=('SKIP'
- 'SKIP')
+source=("git+https://gitlab.freedesktop.org/dbus/dbus.git")
+sha256sums=('SKIP')
pkgver() {
@@ -36,7 +34,10 @@ build() {
--with-system-socket="/run/dbus/system_bus_socket" \
--with-console-auth-dir="/run/console" \
--with-systemdsystemunitdir="/usr/lib/systemd/system" \
- --with-dbus-user=dbus --enable-systemd --enable-user-session --enable-epoll
+ --with-dbus-user="dbus" \
+ --enable-systemd \
+ --enable-user-session \
+ --enable-epoll
make
}
@@ -54,7 +55,9 @@ package() {
rm -r "$pkgdir/usr/share/doc"
rm -r "$pkgdir/var/run"
- install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/dbus/COPYING"
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/dbus"
- install -Dm644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+ # We have a pre-assigned uid (81)
+ echo 'u dbus 81 "System Message Bus"' |
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
}