summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-10-08 18:42:42 -0400
committerVincent Grande2020-10-08 18:42:42 -0400
commit2b1a7d6ed5c1992f60f7b443d0a4a7ac070d3b6c (patch)
treee959e279002abeafa1e7ba244bbb388bdca47903
downloadaur-2b1a7d6ed5c1992f60f7b443d0a4a7ac070d3b6c.tar.gz
initial upload
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD138
-rw-r--r--dbus.install18
-rw-r--r--dbus.sysusers1
-rw-r--r--dbus.tmpfiles1
-rw-r--r--no-fatal-warnings.diff13
6 files changed, 206 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9670c0b38b92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = dbus-nosystemd-git
+ pkgdesc = Freedesktop.org message bus system
+ pkgver = 1.12.20
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/dbus/dbus
+ install = dbus.install
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = python
+ makedepends = git
+ makedepends = autoconf-archive
+ depends = expat
+ conflicts = dbus-eudev
+ source = git+https://gitlab.freedesktop.org/dbus/dbus.git
+ source = dbus.tmpfiles
+ source = no-fatal-warnings.diff
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = dbus-nosystemd-git
+ depends = expat
+ depends = libaudit.so
+ provides = libdbus
+ provides = libdbus-1.so
+ provides = dbus
+ conflicts = libdbus
+ conflicts = dbus
+ replaces = libdbus
+
+pkgname = dbus-docs-nosystemd-git
+ pkgdesc = Freedesktop.org message bus system (documentation)
+ depends =
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b53641a4b419
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,138 @@
+# Maintainer : Vincent Grande <shoober420@gmail.com>
+# Contributor : Eric Vidal <eric@obarun.org>
+# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
+# Contributor : Jan de Groot <jgc@archlinux.org>
+# Contributor : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor : Tom Gundersen <teg@jklm.no>
+# Contributor : Link Dupont <link@subpop.net>
+
+pkgdesc="Freedesktop.org message bus system"
+
+pkgver=1.12.20
+pkgrel=1
+
+url="https://gitlab.freedesktop.org/dbus/dbus"
+
+source=(
+ "git+https://gitlab.freedesktop.org/dbus/dbus.git"
+ 'dbus.tmpfiles'
+ 'no-fatal-warnings.diff')
+
+makedepends=(
+# 'xmlto'
+# 'docbook-xsl'
+ 'python'
+# 'yelp-tools'
+# 'doxygen'
+ 'git'
+ 'autoconf-archive')
+
+pkgver() {
+ cd dbus
+ git describe --tags | sed 's/^dbus-//;s/-/+/g'
+}
+
+prepare() {
+ cd dbus
+
+ # Allow us to enable checks without them being fatal
+ patch -Np1 -i ../no-fatal-warnings.diff
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+_path=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --libexecdir=/usr/lib/dbus-1.0
+ runstatedir=/run
+)
+
+_flags=(
+ --with-system-pid-file=/run/dbus/pid
+ --with-system-socket=/run/dbus/system_bus_socket
+ --with-dbus-session-bus-listen-address=unix:runtime=yes
+ --with-dbus-session-bus-connect-address=autolaunch:
+ --with-dbus-user=dbus
+ --with-console-auth-dir=/run/console/
+ --without-systemdsystemunitdir
+ --without-x
+ --enable-inotify
+ --disable-static
+ --disable-verbose-mode
+ --disable-asserts
+ --disable-systemd
+ --disable-user-session
+ --disable-x11-autolaunch
+ --disable-checks
+ --disable-xml-docs
+ --disable-doxygen-docs
+ --disable-ducktype-docs
+ --disable-libaudit
+)
+
+build() {
+ cd dbus
+
+ ./configure "${_path[@]}" "${_flags[@]}"
+ make
+}
+
+#check() {
+# make -C dbus check
+#}
+
+package_dbus-nosystemd-git(){
+ depends+=('libaudit.so')
+ provides=('libdbus' 'libdbus-1.so' 'dbus')
+ conflicts=('libdbus' 'dbus')
+ replaces=('libdbus')
+
+ DESTDIR="$pkgdir" make -C dbus install
+
+ rm -r "$pkgdir"/{etc,var}
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+
+ ## systemd-sysusers
+ #install -D -m0644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+ ## systemd-tmpfiles
+ install -D -m0644 "$srcdir/dbus.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/dbus.conf"
+
+ ## Split docs
+ mv "$pkgdir/usr/share/doc" "$srcdir"
+}
+
+package_dbus-docs-nosystemd-git(){
+ pkgdesc+=" (documentation)"
+ depends=()
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+
+ mv doc "$pkgdir/usr/share"
+}
+
+pkgname=(
+ 'dbus-nosystemd-git'
+ 'dbus-docs-nosystemd-git')
+
+arch=('x86_64')
+
+depends=(
+ 'expat'
+# 'audit'
+)
+
+conflicts=(
+ 'dbus-eudev')
+
+install='dbus.install'
+
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+license=(
+ 'GPL'
+ 'custom')
diff --git a/dbus.install b/dbus.install
new file mode 100644
index 000000000000..f381070479d8
--- /dev/null
+++ b/dbus.install
@@ -0,0 +1,18 @@
+pre_install() {
+
+ groupadd -r -g 81 dbus
+ useradd -M -N -r -u 81 -g 81 -d / -s /sbin/nologin -c "system message bus" dbus
+}
+
+post_install() {
+
+ ## Set permissions on dbus-daemon-launch-helper
+
+ chown root:dbus /usr/lib/dbus-1.0/dbus-daemon-launch-helper
+ chmod 4750 /usr/lib/dbus-1.0/dbus-daemon-launch-helper
+}
+
+post_upgrade() {
+
+ post_install
+}
diff --git a/dbus.sysusers b/dbus.sysusers
new file mode 100644
index 000000000000..f509703d04d2
--- /dev/null
+++ b/dbus.sysusers
@@ -0,0 +1 @@
+u dbus 81 "System Message Bus"
diff --git a/dbus.tmpfiles b/dbus.tmpfiles
new file mode 100644
index 000000000000..14d81bf04733
--- /dev/null
+++ b/dbus.tmpfiles
@@ -0,0 +1 @@
+d /run/dbus 0755
diff --git a/no-fatal-warnings.diff b/no-fatal-warnings.diff
new file mode 100644
index 000000000000..459da9047a50
--- /dev/null
+++ b/no-fatal-warnings.diff
@@ -0,0 +1,13 @@
+diff --git i/dbus/dbus-internals.c w/dbus/dbus-internals.c
+index 267aef97..b1064e85 100644
+--- i/dbus/dbus-internals.c
++++ w/dbus/dbus-internals.c
+@@ -185,7 +185,7 @@ const char *_dbus_no_memory_message = "Not enough memory";
+
+ static dbus_bool_t warn_initted = FALSE;
+ static dbus_bool_t fatal_warnings = FALSE;
+-static dbus_bool_t fatal_warnings_on_check_failed = TRUE;
++static dbus_bool_t fatal_warnings_on_check_failed = FALSE;
+
+ static void
+ init_warnings(void)