summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2022-03-05 10:22:46 +0100
committerNicolas Iooss2022-03-05 10:22:46 +0100
commit1e5b519d7eb4a4415b09b0a917151a7116aa7547 (patch)
tree224ec11092d1b3ec8b6e8237e6eb893a32761c92
parent942b68a097008c14888eb2d08009d3ae20560a3c (diff)
downloadaur-1e5b519d7eb4a4415b09b0a917151a7116aa7547.tar.gz
dbus-selinux 1.14.0-1 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--no-fatal-warnings.diff8
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2499d65c15c6..d6c3c7977c00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dbus-selinux
pkgdesc = Freedesktop.org message bus system with SELinux support
- pkgver = 1.12.20
+ pkgver = 1.14.0
pkgrel = 1
url = https://wiki.freedesktop.org/www/Software/dbus/
arch = x86_64
@@ -21,13 +21,13 @@ pkgbase = dbus-selinux
depends = systemd-libs-selinux>=242.84-2
depends = expat
depends = audit
- source = git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-1.12.20
+ source = git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-1.14.0
source = dbus-reload.hook
source = no-fatal-warnings.diff
validpgpkeys = DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90
sha256sums = SKIP
sha256sums = d636205622d0ee3b0734360225739ef0c7ad2468a09489e6ef773d88252960f3
- sha256sums = 6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e
+ sha256sums = c10395be67e1127a58d7173b587fbbf16f8a8b271c41293558fcf9e27c185478
pkgname = dbus-selinux
depends = systemd-libs-selinux>=242.84-2
@@ -38,8 +38,8 @@ pkgname = dbus-selinux
provides = libdbus
provides = libdbus-1.so
provides = libdbus-selinux
- provides = dbus=1.12.20-1
- provides = selinux-dbus=1.12.20-1
+ provides = dbus=1.14.0-1
+ provides = selinux-dbus=1.14.0-1
conflicts = libdbus
conflicts = libdbus-selinux
conflicts = dbus
diff --git a/PKGBUILD b/PKGBUILD
index 2738aac76237..b5e74ca53a4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
# git -C dbus remote set-url origin https://gitlab.freedesktop.org/dbus/dbus.git
pkgbase=dbus-selinux
pkgname=(dbus-selinux dbus-docs-selinux)
-pkgver=1.12.20
+pkgver=1.14.0
pkgrel=1
pkgdesc="Freedesktop.org message bus system with SELinux support"
url="https://wiki.freedesktop.org/www/Software/dbus/"
@@ -24,12 +24,11 @@ groups=('selinux')
# https://github.com/archlinux/svntogit-packages/commit/4e247891655844511c775fba566df270f8d0d55f
depends=('systemd-libs-selinux>=242.84-2' expat audit)
makedepends=(systemd-selinux xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive audit libselinux)
-_commit=a0926ef86f413f18202ffa19cb1433b6ba00ac36 # tags/dbus-1.12.18^0
source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
dbus-reload.hook no-fatal-warnings.diff)
sha256sums=('SKIP'
'd636205622d0ee3b0734360225739ef0c7ad2468a09489e6ef773d88252960f3'
- '6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e')
+ 'c10395be67e1127a58d7173b587fbbf16f8a8b271c41293558fcf9e27c185478')
validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
prepare() {
@@ -48,7 +47,7 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib/dbus-1.0 \
- runstatedir=/run \
+ --runstatedir=/run \
--with-console-auth-dir=/run/console/ \
--with-dbus-user=dbus \
--with-system-pid-file=/run/dbus/pid \
@@ -68,7 +67,7 @@ build() {
}
check() {
- make -C dbus check
+ make -C dbus -j1 check
}
package_dbus-selinux() {
@@ -86,10 +85,12 @@ package_dbus-selinux() {
install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
# Split docs
- mv "$pkgdir/usr/share/doc" "$srcdir"
+ mkdir -p doc/usr/share
+ mv {"$pkgdir",doc}/usr/share/doc
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
}
package_dbus-docs-selinux() {
@@ -97,8 +98,9 @@ package_dbus-docs-selinux() {
depends=()
conflicts=("${pkgname/-selinux}")
+ mv doc/* "$pkgdir"
+
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
- mv doc "$pkgdir/usr/share"
}
# vim:set sw=2 et:
diff --git a/no-fatal-warnings.diff b/no-fatal-warnings.diff
index 459da9047a50..69fa78e49796 100644
--- a/no-fatal-warnings.diff
+++ b/no-fatal-warnings.diff
@@ -1,10 +1,10 @@
diff --git i/dbus/dbus-internals.c w/dbus/dbus-internals.c
-index 267aef97..b1064e85 100644
+index ab498b15..cf86f4ae 100644
--- i/dbus/dbus-internals.c
+++ w/dbus/dbus-internals.c
-@@ -185,7 +185,7 @@ const char *_dbus_no_memory_message = "Not enough memory";
-
- static dbus_bool_t warn_initted = FALSE;
+@@ -193,7 +193,7 @@ static dbus_bool_t warn_initted = FALSE;
+ * threads, the worst that will happen is that warnings get their default
+ * fatal/non-fatal nature. */
static dbus_bool_t fatal_warnings = FALSE;
-static dbus_bool_t fatal_warnings_on_check_failed = TRUE;
+static dbus_bool_t fatal_warnings_on_check_failed = FALSE;