summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-07-12 11:35:02 +0200
committerNicolas Iooss2020-07-12 11:35:02 +0200
commit4b63f881ca40261dab30e5579f96ca0c2d98bdc8 (patch)
tree6855693c586d99532d031677b93c2a422d02c970
parent561ab2f76d89adc55b7966ec06f9a18deea95533 (diff)
downloadaur-4b63f881ca40261dab30e5579f96ca0c2d98bdc8.tar.gz
dbus-selinux 1.12.20-1 update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
-rw-r--r--no-fatal-warnings.diff13
3 files changed, 35 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eb884ae947c..f6fce97feb89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dbus-selinux
pkgdesc = Freedesktop.org message bus system with SELinux support
- pkgver = 1.12.18
+ pkgver = 1.12.20
pkgrel = 1
url = https://wiki.freedesktop.org/www/Software/dbus/
arch = x86_64
@@ -20,12 +20,13 @@ pkgbase = dbus-selinux
depends = systemd-libs-selinux>=242.84-2
depends = expat
depends = audit
- source = git+https://gitlab.freedesktop.org/dbus/dbus.git#commit=a0926ef86f413f18202ffa19cb1433b6ba00ac36
+ source = git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-1.12.20
source = dbus-reload.hook
+ source = no-fatal-warnings.diff
validpgpkeys = DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90
- validpgpkeys = 3C8672A0F49637FE064AC30F52A43A1E4B77B059
sha256sums = SKIP
sha256sums = d636205622d0ee3b0734360225739ef0c7ad2468a09489e6ef773d88252960f3
+ sha256sums = 6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e
pkgname = dbus-selinux
depends = systemd-libs-selinux>=242.84-2
@@ -36,8 +37,8 @@ pkgname = dbus-selinux
provides = libdbus
provides = libdbus-1.so
provides = libdbus-selinux
- provides = dbus=1.12.18-1
- provides = selinux-dbus=1.12.18-1
+ provides = dbus=1.12.20-1
+ provides = selinux-dbus=1.12.20-1
conflicts = libdbus
conflicts = libdbus-selinux
conflicts = dbus
diff --git a/PKGBUILD b/PKGBUILD
index 5251b999eaad..66ac115ef717 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: Link Dupont <link@subpop.net>
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
@@ -12,7 +12,7 @@
# git -C dbus remote set-url origin https://gitlab.freedesktop.org/dbus/dbus.git
pkgbase=dbus-selinux
pkgname=(dbus-selinux dbus-docs-selinux)
-pkgver=1.12.18
+pkgver=1.12.20
pkgrel=1
pkgdesc="Freedesktop.org message bus system with SELinux support"
url="https://wiki.freedesktop.org/www/Software/dbus/"
@@ -24,20 +24,19 @@ groups=('selinux')
depends=('systemd-libs-selinux>=242.84-2' expat audit)
makedepends=(systemd-selinux xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive audit libselinux)
_commit=a0926ef86f413f18202ffa19cb1433b6ba00ac36 # tags/dbus-1.12.18^0
-source=("git+https://gitlab.freedesktop.org/dbus/dbus.git#commit=$_commit"
- dbus-reload.hook)
+source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
+ dbus-reload.hook no-fatal-warnings.diff)
sha256sums=('SKIP'
- 'd636205622d0ee3b0734360225739ef0c7ad2468a09489e6ef773d88252960f3')
-validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
- '3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
-
-pkgver() {
- cd dbus
- git describe --tags | sed 's/^dbus-//;s/-/+/g'
-}
+ 'd636205622d0ee3b0734360225739ef0c7ad2468a09489e6ef773d88252960f3'
+ '6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e')
+validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
prepare() {
cd dbus
+
+ # Allow us to enable checks without them being fatal
+ patch -Np1 -i ../no-fatal-warnings.diff
+
NOCONFIGURE=1 ./autogen.sh
}
@@ -55,12 +54,13 @@ build() {
--with-system-socket=/run/dbus/system_bus_socket \
--with-systemdsystemunitdir=/usr/lib/systemd/system \
--enable-inotify \
+ --enable-libaudit \
--enable-systemd \
--enable-user-session \
+ --enable-xml-docs \
+ --enable-doxygen-docs \
+ --enable-ducktype-docs \
--disable-static \
- --disable-verbose-mode \
- --disable-asserts \
- --disable-checks \
--without-x \
--enable-selinux --enable-libaudit
make
diff --git a/no-fatal-warnings.diff b/no-fatal-warnings.diff
new file mode 100644
index 000000000000..459da9047a50
--- /dev/null
+++ b/no-fatal-warnings.diff
@@ -0,0 +1,13 @@
+diff --git i/dbus/dbus-internals.c w/dbus/dbus-internals.c
+index 267aef97..b1064e85 100644
+--- i/dbus/dbus-internals.c
++++ w/dbus/dbus-internals.c
+@@ -185,7 +185,7 @@ const char *_dbus_no_memory_message = "Not enough memory";
+
+ static dbus_bool_t warn_initted = FALSE;
+ static dbus_bool_t fatal_warnings = FALSE;
+-static dbus_bool_t fatal_warnings_on_check_failed = TRUE;
++static dbus_bool_t fatal_warnings_on_check_failed = FALSE;
+
+ static void
+ init_warnings(void)