summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2017-11-04 10:56:40 +0100
committerNicolas Iooss2017-11-04 10:56:40 +0100
commitfb16a25b8913b85cc0ed1c54872428d9571709be (patch)
treed744f0e4e915fda347c434d40c2da6cd11f0ec62
parent72bd5c77971938a3f90b1b4d4312677cbe3e1901 (diff)
downloadaur-fb16a25b8913b85cc0ed1c54872428d9571709be.tar.gz
dbus-selinux 1.12.0-1 update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--dbus.sysusers6
3 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d43b8f7332f1..8c2a839a96c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dbus-selinux
pkgdesc = Freedesktop.org message bus system with SELinux support
- pkgver = 1.10.24
+ pkgver = 1.12.0
pkgrel = 1
url = https://wiki.freedesktop.org/www/Software/dbus/
arch = i686
@@ -15,22 +15,24 @@ pkgbase = dbus-selinux
makedepends = yelp-tools
makedepends = doxygen
makedepends = git
+ makedepends = autoconf-archive
+ makedepends = graphviz
makedepends = audit
makedepends = libselinux
depends = libsystemd-selinux
depends = expat
- source = git+https://anongit.freedesktop.org/git/dbus/dbus#commit=430643da9da488a0b089868b9aada324f24a1710
+ source = git+https://anongit.freedesktop.org/git/dbus/dbus#commit=98294ab81a4d7ef00b6de5149344d92278c38593
source = dbus.sysusers
validpgpkeys = DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90
validpgpkeys = 3C8672A0F49637FE064AC30F52A43A1E4B77B059
sha256sums = SKIP
- sha256sums = 1ce179ba3a92ad34941d8ac7f53d01d42cbc91d43ada1136492b78c10b5d693d
+ sha256sums = ee7a7a4b2f944cb2e64b9e760efb82589d81872b5b70268356fb73c83c394845
pkgname = dbus-selinux
provides = libdbus
provides = libdbus-selinux
- provides = dbus=1.10.24-1
- provides = selinux-dbus=1.10.24-1
+ provides = dbus=1.12.0-1
+ provides = selinux-dbus=1.12.0-1
conflicts = libdbus
conflicts = libdbus-selinux
conflicts = dbus
diff --git a/PKGBUILD b/PKGBUILD
index fd7469865cb6..8c9866212e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=dbus-selinux
pkgname=(dbus-selinux dbus-docs-selinux)
-pkgver=1.10.24
+pkgver=1.12.0
pkgrel=1
pkgdesc="Freedesktop.org message bus system with SELinux support"
url="https://wiki.freedesktop.org/www/Software/dbus/"
@@ -15,12 +15,12 @@ arch=(i686 x86_64)
license=(GPL custom)
groups=('selinux')
depends=(libsystemd-selinux expat)
-makedepends=(systemd-selinux xmlto docbook-xsl python yelp-tools doxygen git audit libselinux)
-_commit=430643da9da488a0b089868b9aada324f24a1710 # tags/dbus-1.10.24^0
+makedepends=(systemd-selinux xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive graphviz audit libselinux)
+_commit=98294ab81a4d7ef00b6de5149344d92278c38593 # tags/dbus-1.12.0^0
source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit"
'dbus.sysusers')
sha256sums=('SKIP'
- '1ce179ba3a92ad34941d8ac7f53d01d42cbc91d43ada1136492b78c10b5d693d')
+ 'ee7a7a4b2f944cb2e64b9e760efb82589d81872b5b70268356fb73c83c394845')
validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
'3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
@@ -31,7 +31,11 @@ pkgver() {
prepare() {
cd ${pkgbase/-selinux}
- git cherry-pick -n 09cb6d7b467f6d1c6685ee9ccc171f4dddbe1f42
+
+ # Reduce docs size
+ printf '%s\n' >>Doxyfile.in \
+ HAVE_DOT=yes DOT_IMAGE_FORMAT=svg INTERACTIVE_SVG=yes
+
NOCONFIGURE=1 ./autogen.sh
}
@@ -68,8 +72,8 @@ package_dbus-selinux() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgbase/COPYING"
- # systemd-sysusers
- install -Dm644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+ # We have a pre-assigned uid (81)
+ install -m644 "$srcdir/dbus.sysusers" "$pkgdir/usr/lib/sysusers.d/dbus.conf"
# Split docs
mv "$pkgdir/usr/share/doc" "$srcdir"
diff --git a/dbus.sysusers b/dbus.sysusers
index 6e8dcec11386..c6199ede5c44 100644
--- a/dbus.sysusers
+++ b/dbus.sysusers
@@ -1 +1,5 @@
-u dbus 81
+# sysusers.d snippet for creating the D-Bus system user automatically
+# at boot on systemd-based systems that ship with an unpopulated
+# /etc. See sysusers.d(5) for details.
+
+u dbus 81 "System Message Bus"